Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Not applicable

User docs still showing in QVS but no folders mounted

I have unmounted all folders on QVS but still some older documents are showing in the QVS server documents.

How can I clean these out?

These are old documents that I accessed at one time but they are no longer relevant.

Tags (2)
1 Solution

Accepted Solutions
Not applicable

Re: User docs still showing in QVS but no folders mounted

Turned out to be related to "orphaned" Doc CALs.

It's worth noting that the documents were showing the the document names in CAPS but the original files were not in caps. I wonder if this is QV's way of saying you broke something - which I did.

If you are running SBE here's how to get the orphaned CALs back.

http://community.qlik.com/servlet/JiveServlet/download/344300-61977/How-To-Recover-Document-CALs-Ass...

10 Replies
aaroncouran
Contributor III

Re: User docs still showing in QVS but no folders mounted

Is it possible there are qvw's in your "Root Folder"?  Keep in mind that any root folders and mounted folders also expose qvws in subdirectories.

Not applicable

Re: User docs still showing in QVS but no folders mounted

That was my first thought.

I checked my root folder (C:\ProgramData\QlikTech\Documents) but there are only a few .pgo files.

Could the server be caching something?

Not applicable

Re: User docs still showing in QVS but no folders mounted

Another thought:

I think I had Doc CALs assigned to these documents when i changed the qvw names. Could that be a contributing factor?

Not applicable

Re: User docs still showing in QVS but no folders mounted

The way I got rid of them:

  1. Delete the tasks on those files
  2. Then Delete the Files from Source Folders Path (System > Setup > Distribution Services > General)
  3. Then delete it from Mounted folder and Root Folder
  4. Restart the server (actually not necessary but just in case)

The most important thing is to first Delete the tasks before doing anything else.

Not applicable

Re: User docs still showing in QVS but no folders mounted

Thanks for the tip. I think we are on the right track but I don't see Distribution ServicesScreen Shot 2014-03-06 at 9.45.08 AM.png

Not applicable

Re: User docs still showing in QVS but no folders mounted

Do you have Publisher?

If not then the folder where you have all your files and from which Qlikview picks it up and reloads it.

(In Documents Tab, the folder where all the files reside)

Not applicable

Re: User docs still showing in QVS but no folders mounted

I think this may be related to not removing users before renaming/removing the documents from the mounted folders...

I have 20 Doc CALs and it says all CALs are assigned. Clicking through the documents visible under Documents > User Documents I don't see that any Doc CALs are assigned to any of the documents.

I'm thinking that the CALs are somehow reserved and may be linked to these documents that i still see as visible under User Documents.

Not applicable

Re: User docs still showing in QVS but no folders mounted

I don't have Publisher.

These docs resided in a folder that I have since unmounted.

Not applicable

Re: User docs still showing in QVS but no folders mounted

Reading this thread, it seems that I have orphaned some Doc CALs by changing file names or removing files before removing users and un-allocating the Doc CALs.

I am indeed running SBE, which seems to be more difficult to recover orphaned Doc CALs.

Re: How to remove qvw file permanently from live folder and reload engine

Community Browser