Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Not applicable

Web session timeout when using IIS

Hi,

We have some session timeout issues on our web application. I read on qlikview forum that we need to change the timeout settings in QMC and also in config file of web server

However, my question is how to change the web session time out when using IIS. We have already done the changes in QMC but our timeout is still much shorter than what we have defined in QMC. I would assume that this is some where either in the IIS or any other configuration file but need to know which one

Your help will be appreciated

Shah

Tags (1)
6 Replies
Support
Support

Re: Web session timeout when using IIS


There is an Timeout in IIS.

Untitled.png

Bill

Bill - Designated Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.
Highlighted
Not applicable

Re: Web session timeout when using IIS

I changed this to 3 minutes but the application is still timing out after 20 minutes only. I check the application pool settings and if I bring it down to 2 minutes for example, then the application timesout after 2 minutes. However, If I increase that one to 60 minutes, I am still timing out after 20

Apparently the timeout settings of qlikview website does not seem to work. Application pool does timeout when brought less than 20, but If increase it more than 20, then perhaps there is another setting that is controlling the timeout.

I have tested below settings

1) application pool idle time

2) Qlikview website advance settings timeout

2) Qlikview website asp timeout settings

3) QvAjaxZfc asp timeout settings

Please tell me if there is any other setting that I should be looking at. I have also set the timeout settings in QMC to be one hour

Shah

yujiyamane
Contributor II

Re: Web session timeout when using IIS

I had similar issue and resolved it with this way. Hopefully this could help you.

Go to QMC> System> Setup > Performance > Session.

Empty the field values of 'Possible Session Timeout' and 'Maximum Inactive Session Time'  (Empty means no limit)

Support
Support

Re: Web session timeout when using IIS

Hi,

What are you trying to accomplish? That would help with finding you a solution.

Bill

Bill - Designated Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.
Partner
Partner

how to change QVS timeout when having Qlikview web service through IIS

Hi Bill,

 

Need help with QVS timeout.

I want to change QVS timeout and we have Qlik web service through IIS(So we have Qlikview Settings service)

Can you help with the process of setting the Qvs Timeout when having IIS.

 

I am currently following this:

1.  Open IIS manager on the web server
2.  Highlight the Default Web Site (if not using Default Web Site, select the web site which was chosen during the QlikView Settings Service installation process)
3.  Double-click Application Settings 

4.  Right-click in blank space and choose Add
5.  In Name field, enter SocketTimeOutInSeconds, In Value field, entering my equired value  eg 180  as value for 3min, click OK

 

Is there anything else that needs to be done 

I have qlikview 12.10 version

do i need to edit the QVWebServer.exe.config file also?

Kindly help!!

Support
Support

Re: how to change QVS timeout when having Qlikview web service through IIS

If you are running IIS, you should NOT have a QVWebServer.exe.config file! 🙂  When using IIS, you need to have installed the Microsoft IIS Support option in the QVServer installer, and that installs the QVSettings service instead in that case, so it seems something is not quite correct in your environment at the moment, and that may be why things are not working as you expect?

The IIS instructions you pasted are correct as well, just wanted to note that part.

Regards,
Brett

To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.