Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

nadeemsmarty
Contributor II

qvd generator app fails on server

Hi,

I have an app which generates qvd's on the server .

I have scheduled the same on the server but it had failed . so i manually ran the task again from the tasks panel in qmc but it failed again . I tried to run through the log but could not find a possible answer for this .

i would greatly appreciate if someone could help me with this .

I am also attching the log from the server

Regards,

Nadeem

6 Replies

Re: qvd generartor app fails on server

Check if a file with the name Extractor_TDCC_this.qvw.log exists in the same folder as the fiel Extractor_TDCC_this.qvw. That log will contain the information from the execution of the script. If the log file does not exist then open the qvw document, enable the option Generate Logfile in the document properties and reload the document.


talk is cheap, supply exceeds demand
Not applicable

Re: qvd generartor app fails on server

"(2014-12-02 03:18:19) Information: QlikView->Settings->Document Peferences->Generate Logfile in document is not set."

Can you set the application to generate a logfile, that will give you more information on the problem and post that up.

If you are running it on the server, it could be a range of issue going on, paths not found, missing or different named connection etc

log file will help to see

nadeemsmarty
Contributor II

Re: qvd generator app fails on server

hi Gysbert,

Thanks for taking your time to reply .

It is asking for a password for the data source , how do i link a password for this specific qvw file

I have attached the log file 

Not applicable

Re: qvd generator app fails on server

OELDB.png

You are using the integrated security in your connection I believe, so will need to change and put in the correct user/password, or add your server admin account to the security of the DB

hope that helps

Joe

nadeemsmarty
Contributor II

Re: qvd generator app fails on server

hi Joe,

actually i am not using the windows integrated NT security but was already using the correct username and password. when i reloaded the app from the qlikview dektop it was asking for the password then i had to manually supply the password .

But when i scheduled this app on the server it could not ask me for the password hence it was failing . so your screenshot pointed me in the right direction i just checked on allow saving password and there it was ..

I was done. the QVD's are not getting generated when the application is reloading from the server

Thanks

Regards,

Nadeem

Not applicable

Re: qvd generator app fails on server

good stuff, glad to be of help

Community Browser