Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

rdsuperlike
New Contributor III

table not found error

test:

LOAD

DIE_ITEM_NAME,

GDPW

;

SQL

select  DIE.ITEM_NAME as DIE_ITEM_NAME, NVL(MAX(BOM.GDPW),1) as GDPW

from BOW.DIM_BOM_QC BOM, BOW.DIM_ITM_QC WAFER, BOW.DIM_ITM_QC DIE

where BOM.PARENT_ITM_PRODUCTN_ID = DIE.ITM_PRODUCTN_ID

and BOM.COMP_ITM_PRODUCTN_ID = WAFER.ITM_PRODUCTN_ID

and sysdate between BOM.EFF_FROM_DT and BOM.EFF_TO_DT

group by DIE.ITEM_NAME

order by DIE.ITEM_NAME;

store test into test.qvd(qvd);

The above code throws table not found error.

can anyone tell me what the issue is? bcz the sql returns the values.

Tags (2)
3 Replies
alexantone
Contributor

Re: table not found error

Hello rdsuperlike

One question

Does this query function in your database (Sql Server , Access...)?i think no

sysdate? in this query

sysdate could be used in expression ....but not in a query state.

maybe  you can load table one by one

first ..BOW.DIM_BOM_QC BOM, ,

second...BOW.DIM_ITM_QC WAFER

third BOW.DIM_ITM_QC DIE

bye

anbu1984
Honored Contributor III

Re: table not found error

Do you have any other table before test with exactly two fields (DIE_ITEM_NAME,GDPW)? Then tables might have concatenated automatically

Table names are case sensitive. If you have different case for test table in Store statement, then you will get this error. But posted script has same case.

test:

LOAD

DIE_ITEM_NAME,

GDPW

;

SQL

select  DIE.ITEM_NAME as DIE_ITEM_NAME, NVL(MAX(BOM.GDPW),1) as GDPW

from BOW.DIM_BOM_QC BOM, BOW.DIM_ITM_QC WAFER, BOW.DIM_ITM_QC DIE

where BOM.PARENT_ITM_PRODUCTN_ID = DIE.ITM_PRODUCTN_ID

and BOM.COMP_ITM_PRODUCTN_ID = WAFER.ITM_PRODUCTN_ID

and sysdate between BOM.EFF_FROM_DT and BOM.EFF_TO_DT

group by DIE.ITEM_NAME

order by DIE.ITEM_NAME;

 

store test into test.qvd(qvd);

MVP
MVP

Re: table not found error

Hi,

Comment the store statement and check whether the SQL statement executes correctly?  If not then there is an issue withe the database table.  Check whether you are using correct Connection string, hope this may be the issue.

Regards,

Jagan.

Community Browser