Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

qvd1rkqv
New Contributor III

Access Point is not presenting Application or Document

Problem: We have an AD group that is used to distribute a QVW document in access point via publisher. For some reason some users are not getting this document presented to them via Access Point. A user will have access to this doc in addition to others and will get the other docs presented but not the problem doc. Most users and members of the AD group are getting presented this doc just fine. In the webserver logs I see <Global method="GetAdminDocListForUser"><UserId>AD\User</UserId>   for this user and a list of the docs <SourceName>Leadership Dashboards.qvw< that he can access minus the problem doc.

I've tried adding this user explicitly to the target.qvw file permissions. This has no affect.

How does QlikView determine what to present to the user in access point. Does it actually scan the User Applications directory to see what the AD user has file permissions access to?  Any suggestions? Thanks.

1 Solution

Accepted Solutions
danielrozental
Honored Contributor II

Re: Access Point is not presenting Application or Document

Mark, if the document has section access and the users is not listed as an allowed user he will not see the document.

11 Replies
danielrozental
Honored Contributor II

Re: Access Point is not presenting Application or Document

Mark, if the document has section access and the users is not listed as an allowed user he will not see the document.

qvd1rkqv
New Contributor III

Re: Access Point is not presenting Application or Document

Thanks for the reply. We're not using section access at all. I published another version of the application and gave one of the problem users direct access to it and they're still not getting in published.

danielrozental
Honored Contributor II

Re: Access Point is not presenting Application or Document

I've seen problems like this with documents that used to have section access even if it's not currently present, can you confirm this is not the case?

A few ideas to try

- Have you tried restarting the services?

- Is the user able to access the document from a different PC?

- Is the user able to open the document using the thick client?

- Can you try copying the document with a different name, without the meta or shared files?

gainkarthi
Valued Contributor

Re: Access Point is not presenting Application or Document

Are you using NTFS authorization method ?

qvd1rkqv
New Contributor III

Re: Access Point is not presenting Application or Document

Active Directory with IE Plugin

qvd1rkqv
New Contributor III

Re: Access Point is not presenting Application or Document

It sounds like we have used section access on at least 1 app in the past but this app was built from scratch. How can I confirm that section access in not applied other then the check boxes in the document settings?

I have tried copying and any variant or fresh copy of this app I use is not getting presented to these users. Most people in the AD group get it but for some reason a subset of them are not. 

qvd1rkqv
New Contributor III

Re: Access Point is not presenting Application or Document

Whether I try the fat client or access point it does not publish or make available to these users and yes it's AD authenticated users.

danielrozental
Honored Contributor II

Re: Access Point is not presenting Application or Document

Mark, what I would try is rebuilding the application, you could try export and importing the layout into a blank document or something like that.

qvd1rkqv
New Contributor III

Re: Access Point is not presenting Application or Document

We found that we had an object that was loading data from a data model that had section access applied. Problem solved. Thanks for all the help.