Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Ajax client does not show changes (Caching problem?)

Every time, we change an existing qvw-file and copy it to the QV-server it does not show all changes.

For example, we changed replaced a column in a pivot table by another. After publishing on the server it shows the pivot table without both of this columns. This only happens wen we opened the old version of the report some time before. When we open the report with an user, which did never open that document, everything is shown well.

We tried to restart the browser, delete all cached files, cookies, used "remove last document state" in the overview page. - Nothing helps.

Is there anything on server we have todo?

Greetings,

Michael

8 Replies
Employee
Employee

Re: Ajax client does not show changes (Caching problem?)

Hi,

Can you tell me if you have "Allow only one copy of document in memory" checked?

1.png

Bill

Not applicable

Re: Ajax client does not show changes (Caching problem?)

Hi Bill,

yes, it is checked

Employee
Employee

Re: Ajax client does not show changes (Caching problem?)

Hi,

What version of Qlik and have you tried it with other browsers?

Bill

jerrysvensson
Valued Contributor II

Re: Ajax client does not show changes (Caching problem?)

Strange, we have seen this also. But a clearing of cache files solves it.

Running IE9 and 11 SR2.

Not applicable

Re: Ajax client does not show changes (Caching problem?)

11.20 SR6

Tried that in IE9, FF and Chrome.

At all browsers the same behavior

Employee
Employee

Re: Ajax client does not show changes (Caching problem?)

Hi,

I have not seen this with any of the accounts I work with. Do you have a proxy server that might be caching the data?

Bill

Not applicable

Re: Ajax client does not show changes (Caching problem?)

No,

I have removed the proxy in the browser settings, the problem still exist.

I found a workarround to solve the problem.

When I add a new Bookmark (No bookmarks used before) and tick the option "With layout", The column will be displayed, even when I remove the Bookmark after that.

That's strange and not the solution I want to communicate to the users, but at least the view to the data is now correct

Not applicable

Re: Ajax client does not show changes (Caching problem?)

Sorry, wrong information,

Bookmarks do not correct the view

Community Browser