Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Employee
Employee

All Variables in QV10 SR5 getting erased after Publisher reload

This is really strange.  I have a client who has created variables manually in the variable editor.  They are maintained in the input boxes.  After a reload on server, users can't see any data,  The variables are still there.  But they are empty.  There is no macro or load script routine that would do that.  There are no triggers.  The problem is not consistent.  It only happens intermittently. 

I am not sure if this is related in any way, but I am using the clear field function from 11.  It does work and it's not variable related, but perhaps it created some stability issue.  I don't see why this would only occur during a publisher reload if that's the case though.

Tags (2)
4 Replies

Re: All Variables in QV10 SR5 getting erased after Publisher reload

Mike

Is the QlikView Change Control being used ?

As that removes variables created using the variable editor.

I always find it safest to explicitly create any variables in the load script.

Best Regards,     Bill

Not applicable

Re: All Variables in QV10 SR5 getting erased after Publisher reload

For publisher to be able to "pick" up any variables, I would say that using them in the loadscript would be the way to go.

Ask customer to test and see what the result ends up to be.

Employee
Employee

Re: All Variables in QV10 SR5 getting erased after Publisher reload

Change control?

There are some variables that get created in the load script too.  Everything gets wiped out.  Even those.

gonzaloruizgonz
Contributor

Re: All Variables in QV10 SR5 getting erased after Publisher reload

Hi, this is Really strange, is the problem intermittent? Have you only recreate the problem in one application? How old is the application, save in different versions? I recommend you try in a new one document. When you open the application in desktop are you working in AJAX/WebView?

BR//Gonza