Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Different report results in design client vs published to web

Does anyone have any idea why I would get different results between the design client and the published results? The published results are missing entire categories of data.

I have created and published many reports over the past several months and this is the first time I have noticed anything like this.

I am using Qlikview 9 SR1.

Any ideas of a place to look would be appreciated.

Kal

6 Replies
disqr_rm
Valued Contributor III

Different report results in design client vs published to web

Very strange. I am assuming that you don't have any section access to reduce data based on user name or type, or anything in that nature.

Any chance you can test with SR4? I have worked on many reports on SR1 as well, but never seen such a problem.

Anyway, good to know another QV person in Atlanta..

Rakesh Mehta
Atlanta :-)

Not applicable

Different report results in design client vs published to web

Thanks for your suggestions Rakesh,

I do use section access for data reduction, but I have access to everything on the report. Either way I expect it to see identical results in the designer as I do a published report with full access.

In the report I am displaying phone calls with a drill down group that starts with a month then down to a manager, then to a sales rep, then the number of calls made. In some cases the missing data is an entire manager and underlying sales people, and sometimes there are missing sales people under the a manager.

This report has been in production for quite some time with few problems. I made a change recently, but have backed out the change trying to understand and correct the problem.

I am going to upgrade my design client for the heck of it as I am seeing other odd things as well (design elements displayed on the published report that I have deleted from the report in the designer).

Are you part of the Qlikview group in Atlanta?

Kal

disqr_rm
Valued Contributor III

Different report results in design client vs published to web

Sure Kal. Let me know how it behaves after upgrade.

Yes, I am part of Atlanta group, but it's been long we had any group meet here in town. Would be nice to get together and share ideas in-person. Hopefully we see something soon.

Rakesh

Not applicable

Different report results in design client vs published to web

Hi Kal,

Were you able to figure this out? I have the same exact situation. An application using Section Access is returning different results when I use it on the desktop version than when I use it from the server via Access Point. The frustrating part is that I believe the desktop results are the correct ones. I too am using an account that has full access to the data.

Thanks (from Boston),

Arturo

Not applicable

Different report results in design client vs published to web

hello..

is there any solution?

Not applicable

Different report results in design client vs published to web

I rebuilt my report query by query eliminating anything I did not absolutely need and I got the report to display the design elements I expected. In the end the new report was not much different than the old, but it worked.

Kal

Community Browser