Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Not applicable

Different result in qvw on QV-publisher than on QV site

First: I am very new to this!

A user alerted me to a problem when she looked at some Sales Analysis data, there where things missing for November.

When I had a closer look, I can see that the qvw looks fine in preview on QV-publisher, but on the QV site there is data missing for September to December but only for data from one company. The data for other companies looks fine.

How can the same qvw look (partially) different on QV-publisher and on the QV site/web page?

Tags (2)
7 Replies
fchukoskie
Contributor

Re: Different result in qvw on QV-publisher than on QV site

Whenever I've seen that symptom, it's ended up being a Section Access security issue.

See if you can find what the Section Access reduction field for that particular user would be, and then filter to that in Desktop to try to reproduce the problem.

Re: Different result in qvw on QV-publisher than on QV site

Does your document have section access?

The user account running the QDS (QlikView Distribution Service) must have permissions in section access to access all data.

Not applicable

Re: Different result in qvw on QV-publisher than on QV site

Problem solved.

I am not sure how to explain this but one salesman was registered with both "Firstname Lastname" and "FirstnameLastname" in our system but only with a space in basic data for QV.

Still very confused why QV-publisher didn't care and showed me the information connected to both version of the name.

hirishv7
Honored Contributor

Re: Different result in qvw on QV-publisher than on QV site

Hi,

Is that App working fine  with your login on the access point ??

-Hirish

Not applicable

Re: Different result in qvw on QV-publisher than on QV site

The App worked fine, but there was a lot of data missing for Sept - December when we looked at it via Access Point. On QV-publisher all data that we expected should be there was there. That was very confusing. To me that did not indicate that a load had gone wrong. I thought it was some security or cache issue.

I guess the app in access point did show the correct data based on how the basic data was setup, that is "FirstName LastName". When the app was viewed in QV-publisher, data with both "FirstNameLastName" and "FirstName LastName" was included.

I am still very confused why there was a difference between access point and QV-publisher...

hirishv7
Honored Contributor

Re: Different result in qvw on QV-publisher than on QV site

Hi,

Try like this ,

Make application with no  section access and reload in your QMC.

-Hirish

Re: Different result in qvw on QV-publisher than on QV site

If I can interprete your statement "qvw look (partially) different on QV-publisher" as "qvw looks different when opened in QV Desktop on the Publisher machine", then you should know that the user roles are treated differently in QV Desktop than in the AccessPoint. Especially the ADMIN roles. In QV Desktop, they will see everything by default. In the AccessPointt, everyone is treated as a USER. As a result, conflicts in SA won't be visible in QV Desktop in the same way as they are in the AP.

Your "issue" can have other origins too. However with the minimal information available, it is very difficult to pinpoint the real cause.

Peter

Community Browser