Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Disable SNMP in qlikview?

Hello, does anyone know if it is possible to change the SNMPPort in Qlikview or totally disable it?

Ived tried the different solution in the community (EnableSNMP=0) and writning in regedit, but everytime I reboot qlikview takes control over port 161.

Anyone with a solution to this problem?

Tags (1)
1 Solution

Accepted Solutions
Employee
Employee

Re: Disable SNMP in qlikview?

I just tried both of these settings and they work on my server.

SNMPPort=

EnableSNMP=0

Bill

12 Replies
Employee
Employee

Re: Disable SNMP in qlikview?

Yes,  to disable it.

Set the EnableSNMP Value to 0 in The QlikView Server Settings.ini ( This will stop SNMP for QlikView Server )

  • You will need to add this string " EnableSNMP=0 " to the settings.ini under the [Settings 7] line
  • Set the Key EnableSNMP to false in the File C:\Program files\Qlikview\Distribution Service\QVDistributionService.exe.config ( This will stop SNMP for Qlikview Distribution Service ), restart the Qlikview Distribution Service to apply the setting.

To change the port

Qlikview Distribution Service

<!-- ************ SNMP Settings in C:\Program files\Qlikview\Distribution Service\QVDistributionService.exe.config ************ -->

<!-- Set to true to enable snmp listener -->

<add key="EnableSNMP" value="false"/>

<!-- Port to use for Snmp. -->

<add key="SNMPPort" value="4721"/>

Not applicable

Re: Disable SNMP in qlikview?

1: I allready had EnableSNMP in my settings.ini

2. The key Enable SNMP in DistributionService.exe.config was already set to false

3. I thought SNMP was using port 161? and not 4721?

How come if the port is 4721 it then takes over port 161?

Not applicable

Re: Disable SNMP in qlikview?

Anyone with a solution? What BILL BRITT wrote, does not work.

Qlikview still blocks/binds to port 161/162

Employee
Employee

Re: Disable SNMP in qlikview?

I have not tested the enablesnmp but it should work.What version are you running? Can you try

1.Open 'Settings' file
2. Under the [Settings 7] line add a line:

SNMPPort=<xxxxxx> (anything other than 161 to change the Port)
C:\ProgramData\QlikTech\QlikViewServer

You will need to stop QVS then restart it after you add the line.

Bill

Employee
Employee

Re: Disable SNMP in qlikview?

I just tried both of these settings and they work on my server.

SNMPPort=

EnableSNMP=0

Bill

Not applicable

Re: Disable SNMP in qlikview?

Im running server 11.2.

Ill try to set it into settings.ini.

Hopefully this will work!

Does it also work if you restart your server?

Employee
Employee

Re: Disable SNMP in qlikview?

Yes, restarting the server will do it too.

Bill

Not applicable

Re: Disable SNMP in qlikview?

Thanks for the help, very appreciated!

Not applicable

Re: Disable SNMP in qlikview?

Didnt work - after restart?

Community Browser