Qlik Community

Ask a Question

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Welcome to our newly redesigned Qlik Community! Read our blog to learn about all the new updates: READ BLOG and REPORTED ISSUES
Showing results for 
Search instead for 
Did you mean: 

Distribution Task Failed - Failed to Connect to QlikView Server

Hi Everyone,

Hoping someone can help me out. Attached is an excerpt of the governance dashboard distribution log. I get a failed to connect to QlikView Server error. All distribution tasks we have are failing with the exact same log error. Appears from the log that document reloads fine, but just doesn't get distributed to the Access Point.

Whats interesting is that this came out of nowhere, things were fine a day before these errors started showing up.

Our IT department has not been able to figure it out yet.

I am in a tough spot as production reports are affected by this. So would really appreciate any help.

Thank you!

3 Replies

Hello Shariq,

If things were running fine the day before and all of a sudden ALL of your tasks are failing on the distribution portion, then I would think the issue would be environmental, not a QlikView error, per se.

The error in the log provided:

ErrorFailed to connect to QlikView Server. This error is most likely because the server is not contactable or that the account the QlikView Distribution Service is running as is lacking permissions. Address=QlikViewStorage:4747, Exception=System.Net.Sockets.SocketException (0x80004005): An attempt was made to access a socket in a way forbidden by its access permissions

points to potential network issue. Have you confirmed port 4747 is open? When doing a server distribution, the traffic is over the QVP protocol on port 4747. If you configure the task to use a folder distribution instead of server distribution, does it still error out?

Hope this helps


Sr. Technical Support Engineer with Qlik Support

Hi Chip,

Thanks for the response.

I just ran the task to distribute to folder and it worked without errors.
I will check with IT regarding port 4747 as you mentioned first thing Monday morning!




Hey there Shariq. Glad to hear that the distribute to folder worked.

Sr. Technical Support Engineer with Qlik Support