Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Luminary
Luminary

Distribution failed after changing AD LDAP setting in DSC

Hi, all.

We recently migrated our QlikView servers to a new Active Directory domain.  The migration went well, and we got our licenses reassigned to use LDAP on the new AD without a problem.  I did leave the previous LDAP setting as secondary during the migration to give us time to migrate bookmarks and catch any users we might have missed.

When we had to cut the old AD completely, our Distribution stopped working.  Nothing will publish to the QVS for the Access Point.  It's always the same error:

QDSMain.Exceptions.TaskFailedException: Task execution failed with errors to follow. ---> QDSMain.Exceptions.DistributeToResourcesFailedException: Distribute to resource failed. ---> QDSMain.Exceptions.DscOffLineException: Failed to AddNamedUsers at QDSMain.Support.DSCHelper.AddNamedUsers(ILogBucket logBucket, XmlDocument xml, List`1 namedUsers, FileSystemPluginHelper fileSystemPluginHelper)

   at QDSMain.Support.DSCHelper.GetFileSystemSecurity(ILogBucket logBucket, FileSystemPluginHelper fileSystemPluginHelper, List`1 recipients)

   at QDSMain.QlikViewServerDistributionResource.CreateSettingsBlock(ILogBucket i_LogBucket, FileSystemPluginHelper i_FileSystemPluginHelper, String i_SourceDocumentName, DateTime

These documents distribute to all authenticated users.  I even tried 'All Users', with the same result.

None of our authenticated users are trying to hit the old domain.  We cleared out (or migrated) every bookmark from the old AD users.

I cannot find a single setting or note that references the old AD LDAP, but I'm still getting this message. 

Any input would be greatly appreciated.  Thanks!

1 Solution

Accepted Solutions
Luminary
Luminary

Re: Distribution failed after changing AD LDAP setting in DSC

This issue has been resolved. 

Someone had turned off the QVS service on our Publishing Server after being told it was 'best practice'.  When I started that service again, everything went back to normal. 

I don't know if I'm violating some best practice by running QVS on my publishing server, but I do know that I need it running to keep my document distribution flowing.

I apologize for the misleading question involving the AD switch.  The timing and the contents of the log just made that seem relevant to the cause.

3 Replies

Re: Distribution failed after changing AD LDAP setting in DSC

Is the AD User that runs the QlikView Windows Services in the new domain and is it a Local Admin + in the local QlikView Administrators Group

Luminary
Luminary

Re: Distribution failed after changing AD LDAP setting in DSC

Hi, Bill.  Thanks for the quick reply.

The answers are yes and yes.  I've verified that more than once this morning, just to be sure. 

Luminary
Luminary

Re: Distribution failed after changing AD LDAP setting in DSC

This issue has been resolved. 

Someone had turned off the QVS service on our Publishing Server after being told it was 'best practice'.  When I started that service again, everything went back to normal. 

I don't know if I'm violating some best practice by running QVS on my publishing server, but I do know that I need it running to keep my document distribution flowing.

I apologize for the misleading question involving the AD switch.  The timing and the contents of the log just made that seem relevant to the cause.

Community Browser