Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Not applicable

Error message in Publisher "Failed to create QlikView Engine"

Hello,

since we have migrated our server to QV10 SR2 (from QV9 sr2), we have some error in Publisher to reload or distribute. We get this error message in the application event viewer :

Failed to create QlikView Engine.. Exception=System.ComponentModel.Win32Exception: Insufficient quota to complete the requested service

at System.Diagnostics.NtProcessManager.GetProcessIds()

at System.Diagnostics.ProcessManager.GetProcessIds(String machineName)

at System.Diagnostics.Process.GetProcessById(Int32 processId, String machineName)

at QVBWrapper.Document.CreateQVBProcess(ILogBucket i_LogBucket)

The applications haven't changed, the only change we have done is the upgrade of Qv server version.

Did someone get this issue ?

Any idea ?

Thanks

Gilles

Tags (2)
23 Replies
Employee
Employee

Error message in Publisher "Failed to create QlikView Engine"

Does it occur at every execution or just randomly? Is it on all tasks or a subset of them?

Not applicable

Error message in Publisher "Failed to create QlikView Engine"

It occurs randomly : not every day, not every execution and not on same task.

danielrozental
Honored Contributor II

Error message in Publisher "Failed to create QlikView Engine"

Gilles, take a look at this thread.

http://qlikcommunity.qliktech.com/thread/22015

Not applicable

Error message in Publisher "Failed to create QlikView Engine"

Thanks Daniel for your feedback.

I have already read this thread. I have changed the cpu throttle to 85 % but it doesn't have effect. So i put it back to 0 because I also read in the QVS reference manual that this setting should not be changed in case of dedicated QVS server (page 114). this is my case.

One strange thing : i cannot set the max documents reload as this is not available in the qemc (see attached jpeg).qemc_performance.jpg

Gilles

danielrozental
Honored Contributor II

Error message in Publisher "Failed to create QlikView Engine"

Gilles, do you have a publisher license?

If so, you will find a setting "Max number of simultaneous QlikView engines for distribution" in the QlikView Distribution Service.

A few recommendations:

- Spread tasks apart, don't have multiple tasks starting at the same time.

- You should try chaining your tasks when possible. With previous versions as each task will only use a single processor it made more sense to run as many as possible in parallel, now with QV10 as each task will use several cores it might make sense just to trigger each after the previous has finished.

- Never run more than 9 tasks in parallel (this isn't really a recommendation, it's a limitation).

CPU Throttle will lower QVS priority once it hits that value, hence allowing you to regain control of the server if something goes wrong. Will probably not help you right here but you might want to consider it if you see your server going to 100% usage and you're not able to regain control.

Not applicable

Error message in Publisher "Failed to create QlikView Engine"

Yes i get a publisher license.

How should I set the “Max nb of simultaneous QlikView engines for distribution” setting? Currently it is set to 4 and I guess it is the default as I haven’t changed it before.

Regarding you recommendations, it is good to know how qv10 is working. But it is not always possible or there is no sense to chain tasks especially when applications are not related.

When I got the error, I had only 2 simultaneous tasks running.

Since I set back the cpu throttle to 0, the error messages are not the same, I had this one on Saturday

Error Failed to connect to QlikView Server. This error is most likely because the server is not contactable or that the account the QlikView Distribution Service is running as is lacking permissions

And yesterday I got

Could not run DSC.GetFileSystemSecurity ---> System.Exception: Directory Service Connector did not respond to Search request

Also yesterday, i saw that the DSC service was shown in the QEMC as disconnected while the service was started in the Services Management Console.

This morning it was the QVWS service which was shown as disconnected.

The system seems to be very unstable and I really don’t know which setting I should change to solve these errors which seem to me related to the V10.

danielrozental
Honored Contributor II

Error message in Publisher "Failed to create QlikView Engine"

Gilles,

If you haven't already you should get in contact with QlikTech support and let them know about your problems.

Has anything else change since the QV9->QV10 upgrade? has the server changed IP addresses as part of the upgrade?

Not applicable

Error message in Publisher "Failed to create QlikView Engine"

Daniel,

except the upgrade from V9 sr2 to V10 sr2, nothing has changed on the server, nor more task or data volume increase.

Before contacting Qliktech support, i tried to get feedback from the community as the errors occur randomly.

I will expose my problem to the supprot.

thank you for you feedback.

Gilles

danielrozental
Honored Contributor II

Error message in Publisher "Failed to create QlikView Engine"

Support will probably ask you to run hardware tests on your server, when you have this many symptoms and it doesn't point to a problem it might be due to a hardware, memory probably, related problem.

Community Browser