Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

natalija
New Contributor III

Error on QMC

Hi Community,

Have you ever see following error on QMC? And how to resolve it?

When I click on the System tab, expand the node “Qlikview Servers” and then click on the QVS@servername node I get the following error :


error1.jpg

error2.jpg


When I click OK. The page is missing a number of configurable tabs such as folder locations etc.

error3.jpg

All the services are running correctly under the same account and the password is entered correctly. The licence key is applied. I can’t see what the problem is….

I am running Qlikview Server 11.20.12904.0 on Windows 2012 R2 x64


The error viewer shows this on error:

Log Name:      Application

Source:        QlikView Management Service

Date: 27/01/2016 19:04:57

Event ID:      0

Task Category: None

Level:         Error

Keywords:      Classic

User: N/A

Computer:      POM-APP02

Description:

  1. System.Exception: Failed to retrieve document list from the specified QVS ||    at QMSBackendCore.Service.ServiceImpl.<>c__DisplayClass23e.<GetUserDocumentList>b__23d() ||    at SolutionGlobal.Collections.ThreadSafeCache`2.CacheItem`1.GetObject() ||    at SolutionGlobal.Collections.ThreadSafeCache`2.Get(TKey key, Func`1 createObjectFunc) ||    at QMSBackendCore.Service.ServiceImpl.GetUserDocumentList(Guid qvsID) ||    at QMSBackendCore.Service.ServiceImpl.Diagnostics.CacheDocumentAvailable()

Event Xml:

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

  <System>

    <Provider Name="QlikView Management Service" />

    <EventID Qualifiers="0">0</EventID>

    <Level>2</Level>

    <Task>0</Task>

<Keywords>0x80000000000000</Keywords>

    <TimeCreated SystemTime="2016-01-27T19:04:57.000000000Z" />

<EventRecordID>87051</EventRecordID>

<Channel>Application</Channel>

<Computer>POM-APP02</Computer>

    <Security />

  </System>

  <EventData>

    <Data>System.Exception: Failed to retrieve document list from the specified QVS ||    at QMSBackendCore.Service.ServiceImpl.&lt;&gt;c__DisplayClass23e.&lt;GetUserDocumentList&gt;b__23d() ||    at SolutionGlobal.Collections.ThreadSafeCache`2.CacheItem`1.GetObject() ||    at SolutionGlobal.Collections.ThreadSafeCache`2.Get(TKey key, Func`1 createObjectFunc) ||    at QMSBackendCore.Service.ServiceImpl.GetUserDocumentList(Guid qvsID) ||    at QMSBackendCore.Service.ServiceImpl.Diagnostics.CacheDocumentAvailable()</Data>

  </EventData>

</Event>

  Can someone please try and help me troubleshoot this?  I have reinstalled Qlikview with the same results. 


Thanks in advance.


1 Reply

Re: Error on QMC

The QlikView Management Service (=the service that provides the QMC with information from the various QlikView Services) cannot connect to the QlikView Server-service. Most of the time, this is caused by improper account credentials, services running under different accounts or a service account with invalid or insufficient privileges.

Is the service account member of the local group QlikView Administrators? And for best results, is it member of the local Administrators group?

Peter

Community Browser