Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Issue when creating new user (Validation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one itemValidation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one item)

Hello !


Since yesterday I have had problems when creating new user (calls and nameds)

I would like to know how to solve the problem below:

"An unhandled error occurred.

Validation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one item"

My license is valid for both, the server and the publisher. and I still have 3 named and 10 calls available.

May this this issue that we are facing an instability on installation?

Is there any xml file corrupted?

Can you help me?

I appreciate any tip you can provide me

Best regards

17 Replies
alexpanjhc
Valued Contributor

Re: Issue when creating new user (Validation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one itemValidation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one item)

Hi

Is this getting resolved? I am having the same issue the only difference is that  when I change the folder location I am seeing this error.

thanks!

diego_a_barboza
New Contributor III

Re: Issue when creating new user (Validation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one itemValidation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one item)

I have exactly the same error message when I try to add a new mounted folder

Not applicable

Re: Issue when creating new user (Validation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one itemValidation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one item)

I am getting this same error when I try to change the folder locations in the Management Console.  Why is this error occurring?

diego_a_barboza
New Contributor III

Re: Issue when creating new user (Validation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one itemValidation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one item)

According to what I was told by my local support team, this should be fixed after upgrading to QV v11 SR3 (our current version was v11 SR2 by that time) however, this didn't fix anything. After giving a second look to it, our local team now says it could be related to some xml files that are not properly set up, so I had to send them a copy of the whole QlikTech Folder so they can check that.

Still waiting on an answer on this.

mvanlutterveld
Contributor II

Re: Issue when creating new user (Validation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one itemValidation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one item)

The same thing here. Very inconvienent trying setting up the QVS environment.

Anyone from QlikTech maybe?

martijn
New Contributor III

Re: Issue when creating new user (Validation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one itemValidation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one item)

Here the same. Any news from QlikTech? We're also on v11 SR3

martijn
New Contributor III

Re: Issue when creating new user (Validation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one itemValidation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one item)

What worked for me was stopping all services, redirect de logfiles to its original place (during installation I moved the logfiles to another location) and restart the services. After that I had to add the license again and it all worked fine again. Even after I redirected the redirected logfiles again. I'm not sure what exactly happend, but I got it fixed again...

agigliotti
Honored Contributor II

Re: Issue when creating new user (Validation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one itemValidation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one item)

Hello,

I'm facing the same issue trying to set authentication to DMS.

I'm using version 11.20 SR4 (11.20.12129.0)

Can someone help me to fix it ?

Many thanks in advance.

Best Regards

diego_a_barboza
New Contributor III

Re: Issue when creating new user (Validation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one itemValidation of QDSSettings object failed: QDSGeneral.ClusterInfo must contain at least one item)

After doing some research, this is how the issue was fixed:

Problem: No changes could be done in the QMC configuration menu, anytime we tried to change something we got the Unhandled error message. We couldn't add publish folders, change email notifications, etc...

Analysis: Our QV installation was set up in two servers: One Server and one Publisher, and only the cluster for Publisher server was working.

Solution; the last lines of the file C:\ProgramData\QlikTech\ManagementService\QVPR\QDSCluster.xml had to be modified, in order to re-define the location of the Server that had issues with the cluster. (the lines are between  </xs:schema> and  </NewDataSet> )

NOTE: This solution will only work if you have set up your Publisher and your Server in different locations. If they are all in the same place, the situation should be different.

Community Browser