Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Michael Terenzi's Monitoring Tool

Hi Together,

Michael Terenzi has developed a very promising monitoring tool -->  http://community.qlik.com/qlikviews/1029  

But unfortunately I can not get the application to run

Can you look my configured qvw version in the attachment and say what I am forgot? I have definitely to bring the monitoring tool to run

on my qv11 / Win2008R2 System and need some advice.

Thank you for your help.

Best Regards,


7 Replies
MVP
MVP

Michael Terenzi's Monitoring Tool

Hi there,

Most likely it will be the configuration of where the log files exist, or something not as expected in the log file.  If you are not running Publisher you may need to comment out any Publisher specific parts of the load.  If you can send a screenshot of where it fails I should be able to point you in the right direction.

Steve

http://www.quickintelligence.co.uk/

Not applicable

Re: Michael Terenzi's Monitoring Tool

Hi Steve,

the publisher is integrated in the qv11 server, right ?

If i run the script i got this....

Unbenannt.JPG

Thank you for your help.

Best Regards,

MVP
MVP

Re: Michael Terenzi's Monitoring Tool

Hi there,

There is a cut down version of Publisher that ships with Server - that allows you to do basic reloads - but the full version allows you to do a lot more.

To get your Ops Monitor working you need to remove the following from line 2 of the Date/Time tab:

, '$(vIIS)'

There may be other variables, later on in that string that need to be removed later.  I can't imagine that this table not being loaded into the Date/Time table will cause you any loss of functionality.

Steve

http://www.quickintelligence.co.uk/

Not applicable

Re: Michael Terenzi's Monitoring Tool

Hi Steve,

thank you for this important information. I remove this variable from script but it does an another error on last step.

Look at this..

Unbenannt.JPG

Here, the debugger reports that he does not find the table. What can I do here ? Thank you very much.

Best Regards,


themichael
Contributor

Michael Terenzi's Monitoring Tool

Hi, the reason for this occurring if you do not have a Publisher installation is because of a small scripting entry. This should check for the Pub files and skip if not present, just need to modify it. I will have an updated version of this within the next day or so as well. For now, try this new script on the Master tab:

Resident MasterTemp; ErrorMode = 0 IF Left(QlikViewVersion(), 2) = 11 Then  Drop Field StartedAt from TaskResults; ENDIF; Drop Table MasterTemp; Drop Table PubTemp;

themichael
Contributor

Michael Terenzi's Monitoring Tool

Also, try replacing the QVSClusternode 1 and ALL Server Name input values with hardcoded names, such as "QEO44088" instead of =CName  ........... the variables are causing problems so just type in the name of the server and you should be good.

Not applicable

Re: Michael Terenzi's Monitoring Tool

Hi Michael,

i download your latest app ver 3.2 and this above posted errors does not appear anymore. But if i convert the OS -app, sys and sec events to .csv files with your delivered macro, it produces a incorrect csv file. Some Columns are empty and muddled. Looked at the attached file:

I have win 2008 R2 in use. Is this maybe the problem ?

Thank you !

Best Regards,

Community Browser