Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
gainkarthi
Valued Contributor

Problem in CUSTOM user authorization

I wanted to connect my accesspoint with Custom user settings,

I did the following changes in the QMC (QV 11.2).

1. NTFS to DMS in authentication.

2. Added custom users.

3. Authentication is login, Type as CUSTOM user, Prefix as CUSTOM\ and Login as Default page.

But having trouble in accessing accesspoint with desired user always ends with login failed error.

Am i missing anything here.

Kindly help.

1 Solution

Accepted Solutions
Employee
Employee

Re: Problem in CUSTOM user authorization

See if this document will help.

Bill

7 Replies
gainkarthi
Valued Contributor

Re: Problem in CUSTOM user authorization

The authentication actually runs against the NTLM, even though i put it as DMS and Custom.

Please look at my windows security log,

An account failed to log on.

Subject:

          Security ID:                    NULL SID

          Account Name:                    -

          Account Domain:                    -

          Logon ID:                    0x0

Logon Type:                              3

Account For Which Logon Failed:

          Security ID:                    NULL SID

          Account Name:                    test

          Account Domain:                    Custom

Failure Information:

          Failure Reason:                    Unknown user name or bad password.

          Status:                              0xc000006d

          Sub Status:                    0xc0000064

Process Information:

          Caller Process ID:          0x0

          Caller Process Name:          -

Network Information:

          Workstation Name:          PC136428

          Source Network Address:          fe80::4c99:3d91:5b25:35f

          Source Port:                    56590

Detailed Authentication Information:

          Logon Process:                    NtLmSsp

          Authentication Package:          NTLM

          Transited Services:          -

          Package Name (NTLM only):          -

          Key Length:                    0

This event is generated when a logon request fails. It is generated on the computer where access was attempted.

The Subject fields indicate the account on the local system which requested the logon. This is most commonly a service such as the Server service, or a local process such as Winlogon.exe or Services.exe.

The Logon Type field indicates the kind of logon that was requested. The most common types are 2 (interactive) and 3 (network).

The Process Information fields indicate which account and process on the system requested the logon.

The Network Information fields indicate where a remote logon request originated. Workstation name is not always available and may be left blank in some cases.

The authentication information fields provide detailed information about this specific logon request.

          - Transited services indicate which intermediate services have participated in this logon request.

          - Package name indicates which sub-protocol was used among the NTLM protocols.

          - Key length indicates the length of the generated session key. This will be 0 if no session key was requested.

Not applicable

Re: Problem in CUSTOM user authorization

Hi,

in addition to your settings, in QMC QVWebServer Authentication tab for type select 'Custom user'.

In login form enter user name, without CUSTOM prefix.

regards

gainkarthi
Valued Contributor

Re: Problem in CUSTOM user authorization

Pap Thanks for the help,

Hai already selected Custom user in web server.

And tried in all the ways ( with custom\ prefix and with out custom\ prefix..etc...).

But No use.

Kindly help.

Not applicable

Re: Problem in CUSTOM user authorization

Hi,

try to change port number of Custom Directory path setting, maybe default value 4735 is occupied by something else.

Employee
Employee

Re: Problem in CUSTOM user authorization

See if this document will help.

Bill

dpietersz
Contributor

Re: Problem in CUSTOM user authorization

Do you have a QlikView Server Enterprise license or Small Busniess licence?

Small Business licensed servers cannot run in DMS mode.

gainkarthi
Valued Contributor

Re: Problem in CUSTOM user authorization

Bill,

The document was very helpful. Disabling the windows authentication helped me to resolve the issue.

Thanks a Lot.

Regards,

Karthi

Community Browser