Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Problem in reloading files from the Reload Engine

Dear all,

I have problem reloading files from reload engine. I have a 64 Bit machine running Windows Server 2008 R2 Standard. My backend database server is Oracle which is a 32 Bit installation. I have both Qlikview developer and Qlikview server 32 Bit installations.

Now when I reload files individually it extracts data from the database properly. But when I try to reload the document from Reload Engine it give the following error...

2/1/2012 12:02:46 PM: 0013  ODBC CONNECT*XUserId*XPassword*

2/1/2012 12:02:47 PM:       Error: SQL##f - SqlState: IM014, ErrorCode: 0, ErrorMsg: [Microsoft][ODBC Driver Manager] The specified DSN contains an architecture mismatch between the Driver and Application

2/1/2012 12:02:47 PM:       General Script Error

2/1/2012 12:02:47 PM:       Execution Failed

2/1/2012 12:02:47 PM:      Execution finished.

Anyone any idea how to resolve this issue ?

Regards

Rajeev Sontakey

4 Replies
rothtd
Contributor III

Problem in reloading files from the Reload Engine

Is it possible that your QVS is actually 64-bit (this would make since due to the advantages of 64-bit QVS over 32-bit QVS)? If so, then the 64-bit QVS can't 'see' the 32-bit Oracle drivers. Your 32-bit QV Developer can, however. Our system is 64-bit everything. QVS, QVP, and all drivers (like Oracle) -- all 64-bit. We had a problem with MS Access a few years back because until Office 2010 Microsoft didn't make a 64-bit driver for Access. Since our QVP/QVS was 64-bit would couldn't use the 32-bit Access driver. It was quite a pain (luckly we didn't need to use Access as a data source).

Not applicable

Problem in reloading files from the Reload Engine

Dear rothtd

I installed 32 Bit version of Qlikview Server so that It searches for 32 Bit Oracle drivers. Still why this architecture mismatch ?

Regards

Rajeev.S

Not applicable

Problem in reloading files from the Reload Engine

Are you using a USER DSN or a SYSTEM DSN from your ODBC connection? I had the exact same problem now, and when I created the SYSTEM DSN the problem was solved.

Regards,

André

Not applicable

Re: Problem in reloading files from the Reload Engine

Dear andrlopes

I did as you said but it won't show the drivers list in the ODBCAD32.exe menu. I just worked around with this issue. I downloaded an ODAC from Oracle site which provided me with OLE DB drivers. I installed it and then in the Qlikview file I selected source as an OLE DB with force 32 Bit option. Then I tried to reload via Reload Engine and it worked. Maybe theres some compatibility issues with ODBC drivers on my system.

This OLE DB thing worked.

Thanks

Community Browser