Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Problem validating QMS API service

I'm trying to follow the instructions in the "QlikView Management API - #1 Setting up a Visual Studio project" doc.

Our QlikView server/publisher is installed on a dedicated server. On this server, I created a QlikView Management API" group and added myself as a member.

Then on my computer in Visual Studio, I tried to validate the API service through Add Service Reference, entering http://servername:4799/QMS/Service in Address, then clicking Go. I got the message "An error occurred while attempting to find services at 'http://servername:4799/QMS/Service'. The details of the error says something like ... unable to connect ... connection attempt failed ... no endpoint listening

Do I have to do some setup of the Service on the server? Not knowing if anything may be necessary, I just went ahead to set up Remote Management Services in QMC and set the url to http://servername:4799/QMS/Service. However, it didn't seem to help in the service validation I was trying to do as part of following the above doc.

What would you suggest I do? FYI, I'm a real novice so please explain in basic terms.

Thanks for your pointers.

Tags (2)
1 Solution

Accepted Solutions
Not applicable

Re: Problem validating QMS API service

It seems it was a firewall/port issue. I got it fixed.

1 Reply
Not applicable

Re: Problem validating QMS API service

It seems it was a firewall/port issue. I got it fixed.

Community Browser