Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Not applicable

Publisher not sending report as an attachment

Hi Guys,

I'm having trouble creating a task for QV Publisher to send my reports daily as an attachment. What I did so far is:

1. I have configured mail server settings, so I receive test e-mails from QMC

2. I created reports in my application and inline table with 'email' field (it currently contains only one value, with my e-mail address in it)

3. I then created a task for mail sending with attachment - I followed instructions from QlikTech vid:

http://www.youtube.com/watch?v=iQMKW2_meqg

Everything looks good... except that the report doesn't get sent and in the 'Status' tab, on task list I can see that Last Execution for this job is 'Never'. I'm clicking it to run and it doesn't starting at all.

What I am missing?

I'm attaching a collection of screenshots from my QMS to show all details of my job. I will be very thankfull for any help here.

Thank you in advance.

Best regards,

Pawel

9 Replies
Employee
Employee

Re: Publisher not sending report as an attachment

Hi Pawel,

See if this will help. This is what I use to test it and have never had an issue. Notice on the loop and reduce I don't select a value there.

Bill

Not applicable

Re: Publisher not sending report as an attachment

I've mined some details from system logging:


2014-07-28 18:22:24.3370495    Error    Could not start task; Task not found. TaskID=223b31f8-e3d7-437f-a640-ae82dfb5dce6

- I still don't know how to fix that, but maybe this casts some light on the issue...

kushalthakral
Contributor II

Re: Publisher not sending report as an attachment

Hi Pawel

Some times PDF generator does not work through which QMC converts report into PDF, so kindly check whether it is working or not, if not then uninstall it and install it again.

software name: PDF XChange

Regards

Kushal Thakral

Employee
Employee

Re: Publisher not sending report as an attachment

I would delete the Task and create a new one.

Bill

Not applicable

Re: Publisher not sending report as an attachment

Hi Kushal,

Thank you for your help.

How can I check whether PDF X Change is working properly or not? I am able to print PDFs for my reports from Qlik all the time.

And have you had similar issue? I am willing to reinstall this component but our administrator will not be pleased for bothering him with reinstallations just to check if it helps...

Kind regards,

Pawel

Not applicable

Re: Publisher not sending report as an attachment

Hi Bill,

I just tried that but still I'm without success. I'm still searching though

Thank you for helping me.

Best regards,

Pawel

Employee
Employee

Re: Re: Publisher not sending report as an attachment

Hi Pawel,

Try following the directions I posted using this QVW. You will nee to edit the script and change the email address from bob@gmail.com to a really email address. I have just tested this on my system and it works with out issues.

Bill

Not applicable

Re: Publisher not sending report as an attachment

Hi!

I have the same problem. Pawel, did you solve it?

I deleted task and created a new. PDF XChange is working well, I can print my report on web. But the task does't execute, on my log file I can see message: "Error Could not start task; Task not found. TaskID=964cd9f0-7ca9-4074-9884-066aa8b5ac49".

Can anybody halp me?

Thank you.

Employee
Employee

Re: Publisher not sending report as an attachment

Hi,

This would be caused by a corrupt QVPR database. I would contact support for help.

Bill

Community Browser