Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

marcos_herrera
Contributor

QDS Task grouped by Publisher Cluster still on Queued

Hi Dear Qlik Community

I have an installation with a cluster with the following specs:

Server 1: QVS, QMC and QDS (Node1)

Server 2: QDS (Node2)

Server 3: QVWS

I want run some task only on Node1, and others on any node, for achieve this requirement I created groups on DefinitionGroups.xml file, restart the three machines and set group on the task, when I run the task, the grouped task to run only on Node 1, the status always still on Queued

All services are running well on each server,

The services are running with the same account on each node and has the following specs:

  • Are included on local administrators group
  • Is a domain Account
  • Are included on QlikView Administrators group
  • Are included on Local Policies – User Right assignment – Log on as a Service

See the distribution file (DistributionGroupDefinition.xml attached file)

3 Replies
marcos_herrera
Contributor

Re: QDS Task grouped by Publisher Cluster still on Queued

Capture.PNG

This is the error

qlikuser2468
New Contributor

Re: QDS Task grouped by Publisher Cluster still on Queued

I have not tested this scenario, but would like to suggest you few steps to test:

Server 1: QVS, QMC and QDS (Node1)

Server 2: QDS (Node2)

Server 3: QVWS

1, (To run a task on Node1), On Server 1, add QVWS, reboot and run task again, if works, then QVWS should be part of Node 1.

2. (if above does not help), ...after step 1, disable all services on Server 2 and 3, reboot and run task again on Node 1, if works, cluster should be looked into.

er_abhichandra
New Contributor III

Re: QDS Task grouped by Publisher Cluster still on Queued

Hi Marcos, you have to set the properties in the xml file correctly.

The first 0 and the next false settings ahve to be set to 1 and true for it to work. you can also specify grace time in minutes as additional parameter as per your requirements.