Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

romain_bourdon
New Contributor II

QMSEDX has stopped working

Hello,

I have a problem with my EDX command. I use it to start reloading my Qlikview tasks and it works well on most of my app.

But for one app, I meet some difficulties that I don't understand. I launch my EDX command, it starts well the target Qlikview task, but fall in error after some seconds with the following message :

     1- I have first a Microsoft Windows error window that shows "QSMEDX has stopped working"

     2- When I click on "Close the program", then the following error message appears in the cmd.exe window (but the Qlikview task has begun and works well):

Unhandled Exception: System.ServiceModel.FaultException: System.Exception: Could

not find a result for the specified execution ID "4c558116-527e-46ec-a5c9-7699c

6a6383d"

Server stack trace:

   at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRunt

ime operation, ProxyRpc& rpc)

   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean on

eway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan tim

eout)

   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCall

Message methodCall, ProxyOperationRuntime operation)

   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:

   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage req

Msg, IMessage retMsg)

   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgDa

ta, Int32 type)

   at QMSEDX.QMSAPI.IQMS.GetEDXTaskStatus(Guid qdsID, Guid executionID)

   at QMSEDX.QMSAPI.QMSClient.GetEDXTaskStatus(Guid qdsID, Guid executionID)

   at QMSEDX.Program.<>c__DisplayClasse.<PollSingleTask>b__d()

   at System.Threading.SpinWait.SpinUntil(Func`1 condition, Int32 millisecondsTi

meout)

   at QMSEDX.Program.PollSingleTask(IQMS client, Guid execId, Int32 pollInterval

, Int32 timeout)

   at QMSEDX.Program.<>c__DisplayClassb.<MonitorTriggeredTasks>b__a(TaskExecutio

nItem item)

   at System.Collections.Generic.List`1.ForEach(Action`1 action)

   at QMSEDX.Program.MonitorTriggeredTasks(IQMS client, List`1 executionItems)

   at QMSEDX.Program.TriggerAndMonitorTask()

   at QMSEDX.Program.Main(String[] args)

Can anybody help me ?

thanks

Romain

1 Solution

Accepted Solutions
jerrysvensson
Valued Contributor II

Re: QMSEDX has stopped working

Regarding QV12, look here:

QMSEDX and QlikView 12

3 Replies
mvluttge
New Contributor III

Re: QMSEDX has stopped working

Has anyone found something on this subject yet?

I have the exact same issue. It worked fine up until a server restart five days ago, and since it has failed (without actually failing) every time.

The QlikView tasks run perfectly, but QMSEDX fails, and throws back a fail to the task scheduler on the sql server.

I get the same message when I run it manually.

Any input would be much appreciated.

BR,

Martin

alan_richmond
Contributor

Re: QMSEDX has stopped working

I too have my QMSEDX that has stopped working on upgrading my test server to qv 12 from qv 11.2

jerrysvensson
Valued Contributor II

Re: QMSEDX has stopped working

Regarding QV12, look here:

QMSEDX and QlikView 12