Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
MVP
MVP

QlikView Publisher Not Sending Alerts

Hi there,

I have a document hosted and reloading on QlikView Publisher (x64 11.20.12235.0 11.2 SR5) which has an alert set up in it.  When the trigger condition is true no alert email is sent out by Publisher.

I've checked all of the obvious things;  The app sends alerts correctly when reloaded in the Desktop.  The 'Batch' tick box is ticked in the Alert set up.  The SMTP set up in Publisher is correct - and alerts on reload failures send correctly.  The same app hosted on a different server (QlikView Server, not Publisher) sends alerts fine.

Has anyone else seen this behaviour?  Any suggestions?

Steve

1 Solution

Accepted Solutions
Employee
Employee

Re: QlikView Publisher Not Sending Alerts

Hi Steve,

This might be a bug. Can you try the below and see if it works? If it does, then the bug was fixed in 11.20 SR6.

Work around:

To enable username/password (ESMTP - AUTH LOGIN) authentication mode for the qvb.exe process add the following key to the settings.ini configuration file located in “C:\Windows\System32\config\systemprofile\AppData\Roaming\QlikTech\QlikViewBatch” and/or “C:\ProgramData\QlikTech\QlikViewBatch”:

SMTP_Authmethod = 2

Explanation:

SMTP_Authmethod = 0 (No authentication)

SMTP_Authmethod = 1 (CRAM MD5)

SMTP_Authmethod = 2 (AUTH LOGIN)

SMTP_Authmethod = 3 (AUTH PLAIN)

SMTP_Authmethod = 4 (NTLM

Bill

9 Replies
Employee
Employee

Re: QlikView Publisher Not Sending Alerts

I'm not entirely sure, but it seems to be related to the fact that Pub is running the reload.  Try setting it up as a Supporting Task instead as that can use qv.exe to run the reload and you should be able to get the desired result.

sudeepkm
Valued Contributor III

Re: QlikView Publisher Not Sending Alerts

do you have any delays setup. Is it an onPostReload type alert.

I think the SMTP server might not be able to send emails to the recipients. Are there any firewall restrictions or sending mail restrictions applied for that Sender.

MVP
MVP

Re: QlikView Publisher Not Sending Alerts

Hi Chris,

I know of ways of working around this - but I am keen that Alerts work as they should do.  If run as a supporting task from qv.exe the error reporting on failed reloads will not work correctly.

Steve

MVP
MVP

Re: QlikView Publisher Not Sending Alerts

Hi Sudeep,

It's an alert (rather than something that runs as a trigger) and it is set to run after reload.


The SMTP settings are correct - as failure emails are sent correctly from the server.  This leads me to believe that there are no SMTP / firewall issues.

Steve

Employee
Employee

Re: QlikView Publisher Not Sending Alerts

Hi Steve,

This might be a bug. Can you try the below and see if it works? If it does, then the bug was fixed in 11.20 SR6.

Work around:

To enable username/password (ESMTP - AUTH LOGIN) authentication mode for the qvb.exe process add the following key to the settings.ini configuration file located in “C:\Windows\System32\config\systemprofile\AppData\Roaming\QlikTech\QlikViewBatch” and/or “C:\ProgramData\QlikTech\QlikViewBatch”:

SMTP_Authmethod = 2

Explanation:

SMTP_Authmethod = 0 (No authentication)

SMTP_Authmethod = 1 (CRAM MD5)

SMTP_Authmethod = 2 (AUTH LOGIN)

SMTP_Authmethod = 3 (AUTH PLAIN)

SMTP_Authmethod = 4 (NTLM

Bill

MVP
MVP

Re: QlikView Publisher Not Sending Alerts

Hi Bill,

Unfortunately I will not be able to make this change on the production server where the issue is occurring.  I will see if the same problem is manifesting itself on another server in that environment, and whether that config change fixes it.

I will post back when I make any progress.

Many thanks for your assistance.

Cheers,

Steve

Luminary
Luminary

Re: QlikView Publisher Not Sending Alerts

Thanks Bill Britt! I ran into the same problem on 11.20 SR5, adding SMTP_Authmethod=2 solved it for me. Note that it didn't work when I left the spaces around the equal sign (SMTP_Authmethod = 2).

Not applicable

Re: QlikView Publisher Not Sending Alerts

Did you figure this out?

MVP
MVP

Re: QlikView Publisher Not Sending Alerts

Yes - it was a bug with SR5 / SR6, if you upgrade to the latest version you should be fine.

Steve

Community Browser