Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

QlikView Session lost

Hi Community

We use QV 11 and the Internet Explorer 8.

I try to specify my problem:

The QV User lost the session after "round about" 30 minutes, but we triggered the Document Timeout on 480 minutes!

We set the value here:

Management Console - System - Setup - Management Service - QlikView Servers - Documents - Document Timeout.

1.Question:

Is this the right place, because we can just set the value here as well:

Management Console - Documents - User Documents - xyz.qvw - Server - Performance - Document Timeout.

2.Question:

Is there a generally communication problem between QlikView 11 and Explorer 8?

3. Question:

Can I change the "killing session time" default settings at the Internet Explorer 8?

Thanks

Michel

1 Solution

Accepted Solutions
garystrader
Not applicable

Re: QlikView Session lost

1. 30 minutes is a significant number.  There are other timeout settings besides the two you listed that will affect this.  There is an IIS timeout setting for the QvAjaxZfc application.  I think the most likely setting affecting you are the QMC System -> Setup -> ServerName -> Performance -> Maximum Inactive Session Time and Possible Session Timeout, both of which are set to 1800 seconds (30 minutes) by default.

Document timeout is unrelated to user session length.  It determines how long the application sits unused in RAM on the server until QVS decides it's safe to flush it from cache.

2. There is not generally a communication problem between QV and IE.

3. You can't control the timeout within IE.  The timeouts are occuring on the server side.

Gary

3 Replies
michael123
Not applicable

Re: QlikView Session lost

1. You can also set it in desktop version under - Settings -> Document Settings -> Server.

I think you need to have your max session time (or null) at all three.

garystrader
Not applicable

Re: QlikView Session lost

1. 30 minutes is a significant number.  There are other timeout settings besides the two you listed that will affect this.  There is an IIS timeout setting for the QvAjaxZfc application.  I think the most likely setting affecting you are the QMC System -> Setup -> ServerName -> Performance -> Maximum Inactive Session Time and Possible Session Timeout, both of which are set to 1800 seconds (30 minutes) by default.

Document timeout is unrelated to user session length.  It determines how long the application sits unused in RAM on the server until QVS decides it's safe to flush it from cache.

2. There is not generally a communication problem between QV and IE.

3. You can't control the timeout within IE.  The timeouts are occuring on the server side.

Gary

fkeuroglian
Not applicable

Re: QlikView Session lost

Hi , you can change and set the session timeout for each document

in the QMC, go to document tab, and then the PERFORMANCE tab , then set the max timeout in seconds

good luck!

Fernando