Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Not applicable

Qlikview 11 EDX

There was a discussion about how to get EDX remote task execution feature in Qlikview 11.

http://community.qlik.com/docs/DOC-2650

Author did include a lot of artifacts which explained the entire new procedure. Unfortunately some of the users were not familiar with Microsoft C# projects and they were having confusion how to make use of these tools. I tried to reply there , but the thread was closed. Intension of this post is to help users who are struggling to replace their old EDX task.

In the abovementioned post you can find an attachment called_CommandLine_v1.exe. Extract this exe to any location of your choice. You will get following files after the extraction

QMSEDX.exe.config & QMSEDX.exe.

Both of these files are essential for executing the task

Following is the syntax for using the exe file

    /// Commandline call:

    ///     qmsedx -task=name [-qms=qmsaddress] [-password=pwd] [-variablename=vname] [-variablevalues=vvalues] [-timeout=timeout] [-pollinterval=interval] [-verbosity=verbosity]          

    /// Arguments:

    ///     -task [REQUIRED]: The name or id of the task to execute.

    ///     -qms [OPTIONAL]: The address of the qms. Default is the local host.

    ///     -password (-pwd) [OPTIONAL]: The password required to execute the task, if set.

    ///     -variablename (-vn) [OPTIONAL]: The name of the variable to pass on to the task, if set.

    ///     -variablevalues (-vv) [OPTIONAL]: A semicolon separated list of values of the variable to pass on to the task.

    ///     -timeout (-to) [OPTIONAL]: How many seconds to wait for the task to finish. Default value is one minute.

    ///     -pollinterval (-pi) [OPTIONAL]: How often to check the status of the task. Default value is every five seconds.

    ///     -verbosity [OPTIONAL]: The level of output, 0-5. 0 will not produce any output and 5 is the most verbose.  

Example

I copied both these files to a server and created a .bat file with following code

C:\Users\Username\Desktop\qmsedx -task="DEV SAP BW ScriptBuilder" -password=123.

(In order to create a bat file, just write your argument in the notepad and save it with extn .bat)

Then i executed it using command line and  the task executed in my publisher. Read the whitepaper that is attached in the previous post for more information

Although the EDX task execution feature went away with 11, it is still easy to execute the task from an external system.

Tags (3)
56 Replies
bgarland
Contributor III

Qlikview 11 EDX

I've got this working via a buuton in my .QVW but it only works for me (I'm the server admin so I have full rights). It doesn't work for other users when they open the .QVW from the Accesspoint. I've added those users to the server groups QlikView EDX and QlikView Management API, but it's still no go.

bgarland
Contributor III

Qlikview 11 EDX

Got it. I just didn't have security set up on the share where the .bat file is located.

Not applicable

Re: Qlikview 11 EDX

Hi,

Could someone help me

on execution of the batch file I get "Failed to start the task due to the following errorSmiley SurprisedtherError"

What am I doing wrong?

Qlikview EDX group is set up on server.

I have applied the qms url part of parameter.

Actually  - my bad I got it working now...

misplaced a . in the batch file

Thanks,

Alex

Not applicable

Re: Qlikview 11 EDX

Hi,

I'm trying to implement EDX on QVS11 without Publisher license.

In the white paper, it mentioned that I need to pass the name of qvw file instead of the task if there is no publisher license. I tried to enter the qvw file in the bat file but it said: Task not found.

My syntax in bat file:

D:\QVforFun\EDX\QMSEDX_CommandLine\qmsedx -task="Reload Check - Every 25th.qvw" -password=" "

pause

I also tried using task name as shown on QMC but received the same error.

May I know what should be the syntax?

Do I need to change anything in QMSEDX.exe.config file? I can see that it has a HOSTNAME in the endpoint address. Should HOSTNAME be replaced by my server name?

Please help.

Thanks!

Not applicable

Re: Qlikview 11 EDX

Hi minority,

I had some problems getting this to work at first.

Are you running this on the server where you have qlikview server installed?

Have you created the Qlikview EDX group on the server?

Syntax looks ok

If you are running from a remote PC on your network try adding the -qms"http://<yourservername>:4799/QMS/SERVICE" parameter

default is localhost

Kind regards,

Alexander

Not applicable

Re: Qlikview 11 EDX

Hi Alex,

I'm running on my local laptop, windows 7 with QVS 11 installed.

I've assigned my login to QlikView EDX group. It's already in Qlikview Administrator group too.

Did you modify QMSEDX.exe.config file?

Thanks!

Not applicable

Re: Qlikview 11 EDX

Hi Minority,

I have not changed the config, but I think it's picking its default values from here, which would be local host.

We have an dedicated server for Publisher, so I added the -qms parameter.

Also you could try adding a dummy password on the task.

I have not tried without a password.

There is one thing actually, change the taskname in QVS, remove all spaces. I had issues getting it to work using spaces in the taskname.

Kind regards,

Alexander

Qlikview 11 EDX

If the qvw resides in a mounted folder, you have to include the folder name as well.

-task='mountedFolderName/myqvw.qvw"

-Rob

Not applicable

Qlikview 11 EDX

Many many thanks Rob and Alex...

I also found out that mounted folder name with space doesn't work..

Thanks so much!

Community Browser