Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Qlikview Distribution Service is running but not working

Hi all,

Currently I have run into a very difficult issue to solve.  About 12 hours ago all tasks stopped running in Qlikview.  If I try to manually start a task in QMC it will not actually start the task (Yes I have automatic refresh on).  I first tried to restart the service and that didn't help.  I then restarted the server and that didn't help either.  I am not sure where else to look.  I have reached out to our QlikView representative but I haven't heard back yet.  We are on QlikView 11 SR5.  Does anyone have any idea what could be going on?  We haven't really done anything to the platform in months so I have no clue what is going on.

Jon

1 Solution

Accepted Solutions
Employee
Employee

Re: Qlikview Distribution Service is running but not working

You can do this:

- stop all services;

- backup directory programdata\distributionservices;

- delete the directory DistributionService;

- start all service, the tasks will be recreated;

- play again

Do you have many tasks? More than 100? Do you change password of Qlikview Services Account?

Ricardo Gerhard
OEM Solution Architect
LATAM
3 Replies
Employee
Employee

Re: Qlikview Distribution Service is running but not working

You can do this:

- stop all services;

- backup directory programdata\distributionservices;

- delete the directory DistributionService;

- start all service, the tasks will be recreated;

- play again

Do you have many tasks? More than 100? Do you change password of Qlikview Services Account?

Ricardo Gerhard
OEM Solution Architect
LATAM
Not applicable

Re: Qlikview Distribution Service is running but not working

I actually figured this one out.  The folder EDXResults was filled to the brim and dumping that seemed to fix the issue.  I am not sure why that fixes the issue so feel free to drop a comment if you know more on that.

Employee
Employee

Re: Qlikview Distribution Service is running but not working

This folder is big, with million of files.

I recommend delete all distributionservice folder as mentioned before.

Ricardo Gerhard
OEM Solution Architect
LATAM
Community Browser