Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Not applicable

Report Editor - removing the empty right hand space when set to Landscape

Hello,

Under Report editor , if the report orientation is set to Landscape , how to remove the spaces on right hand side , in spite of enlarging whole body from left to right

cheers

Donesh

9 Replies

Re: Report Editor - removing the empty right hand space when set to Landscape

I apologize for misunderstanding your requirement. I thought you are trying to remove extra spaces from a particular field.

Re: Report Editor - removing the empty right hand space when set to Landscape

When you try to print it (or save it in pdf by print option) you can set the left and right margin by print option according to your need. Hope this helps..

Not applicable

Re: Report Editor - removing the empty right hand space when set to Landscape

Capture11.PNG
this report is on landscape orientation  , want to enlarge it to maximum to right hand side, thus , there would n't be empty space .

Please advise

gupta_n8
Valued Contributor II

Re: Report Editor - removing the empty right hand space when set to Landscape

You can use Reports Menu>> Report Settings>> Margin Tab.

Set Right Margin as per your requirement

Report Settings.PNG

Not applicable

Re: Report Editor - removing the empty right hand space when set to Landscape

how to enlarge the width too , so that value should not be displayed small ...


Not applicable

Re: Report Editor - removing the empty right hand space when set to Landscape

Hi Donesh,

this isn't to do with your margins, it is the item settings, you have 'fill with aspect' enabled on the chart I believe, with this setting it will try to maintain the aspect view and won't allow you to simply stretch the chart in the report.

You might want to try one of the options and see if they can help.

Another option is re sizing the columns and settings on the actual chart itself rather than in the report. As you widen the base chart, your report will also be affected.

All in all, the report builder is a pain to use, so it will be a fair amount of trial and error to get it looking as you require

hope that helps

Joe

Not applicable

Re: Report Editor - removing the empty right hand space when set to Landscape

Capture11.PNG

Hi Joe,

thanks for the hints , apply "fill" in item setting , it is coming enlarged covering landscape orientation .

but if wanted in multiple page layout after saying "Multiple page" under page heading , page is showing blank under print review ..don't know what to do ?

cheers

donesh


Not applicable

Re: Report Editor - removing the empty right hand space when set to Landscape

It's been years since I have used the report builder I'll be honest. If you actually print it (just to pdf or something) rather than just preview, what does it look like?

Not applicable

Re: Report Editor - removing the empty right hand space when set to Landscape

Hi Joe and everyone,

got the answer, first before we put the object into the layout , we first have to set the page as multi-page and then drop the dashboard object into the layout , then and then only it will run into multipages with data on it .

Cheers

Donesh


Community Browser