Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
dmohanty
Valued Contributor

Report not coming in email for a Particular User?


Hi All,

In one of my QVW screen, I have placed an Input Box, where users have to write their respective work email ids (They are opeing the file in IE Plugin). Then clicking a button beneath it, a report (in excel and PDF) will be sent to that particular email entered.

The Button has a long Macro code written to generate report in email provided.

All the business users including me are able to get that report through mail, but ONE particular user is not able to get any report. He is not getting any errors as well. For other users the report is taking hardly 2 minutes to come through email.

I tried taking his email id and entering at my system and he is able to get the report in his email. but he is not able to do at his system. What could be the possible reasons for it?

PS: We have 150 CALS, and the particular user has a valid licence as well.

Regards!!!

12 Replies
vikasmahajan
Honored Contributor III

Re: Report not coming in email for a Particular User?

Please check following thing

      -   This person's EMAIL id is correctly mapped in macros

      -   Whether Generated mail gone into Junk folder

      -   Whether  in mail server this emails are auto forward to another person

     -    Check with his alternative email whether mails is coming  ?

Hope this help you some !!!

Vikas

dmohanty
Valued Contributor

Re: Report not coming in email for a Particular User?

Hi Vikas,

  • No Email IDs have been hardcoded or mapped in Macros. They are just taken from the input box Around 102 email ids are working fine and those are getting reports in emails, except one particular.
  • No emails are going into Junk Folder. When I am entering his email id at my system, he is getting mails in his inbox. But when he is doing at his own laptop, he is not getting any emails.
  • In mail Server no emails are auto forward to another person.
  • Alternative emails (personal emails) can't be tested as a part of security. But all emails (102 as of now)  available under a particular domain are tested and working fine.

Regards!!


vikasmahajan
Honored Contributor III

Re: Report not coming in email for a Particular User?

PFA

Ony Way of testing is this in this document.

Vikas

vikasmahajan
Honored Contributor III

Re: Report not coming in email for a Particular User?

PFA document as per setting in SMTP server ip test it.

Vikas

richard
Contributor

Re: Report not coming in email for a Particular User?

Check if there are any e-mailrules set in his mailbox.

dmohanty
Valued Contributor

Re: Report not coming in email for a Particular User?

Thank you Vikas for helping hand.

This approach is known to me, but I Have not tested it yet. I will see if this is associated anyway with my approach!

Will let you know.

dmohanty
Valued Contributor

Re: Report not coming in email for a Particular User?

Hi Richard,

Not sure. will check it.

But how come he gets an email, when I am doing it from my system (or some other system). But when he does from his laptop, he never gets an email after clicking the button.

Regards!

richard
Contributor

Re: Report not coming in email for a Particular User?

OK, give it a check.

I think your Windows Eventviewer might give you a good way to search for your solution.

vikasmahajan
Honored Contributor III

Re: Report not coming in email for a Particular User?

Even this approach is helped me lot when I have some issue with our firewall

Good luck.

Vikas

Community Browser