Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

sjoelsona8
New Contributor III

SSL on QlikView Publisher (Version 10)

I am trying to set up and configure SSL on my QlikView server for QlikView Server/Publisher 10 SR1. I am using the QlikView Web Server, not IIS. I've followed the QlikView Server Reference Manual as best I could but I'm unsure of a few setting changes. I hope someone can clarify. Here are my steps so far:

1. Gain a valid certificate for the web site - DONE.

2. Activate SSL (pg 261)

  • Import Certificate - DONE.
  • Get the Thumbprint - DONE.
  • Generate a GUID - DONE.
  • Bind to SSL in Windows Server 2008 - DONE.
  • Additional changes for the QlikView Web Server -


Make changes to config.xml for QlikView Web Server to add the full URL used for SSL. The default location for the config.xml file is C:\Program Files\QlikView\Server\QvWebServer. Note that the URL must match the URL for which the certificate is valid.
<Url>https://QVS.companyx.local:443/</Url>

Need help here. I don't have a <Url></Url> line in my config.xml file. I have a <ConfigUrl>http://_:4750/qvws.asmx</ConfigUrl> line. Do I need to modify this line?

3. Modify the QVManagementService.exe.config file by changing the UseHTTPS value from false to TRUE. (Page 201) -DONE

4. Modify the QvDistributionService.exe.config file by changing the UseHTTPS value from false to TRUE. (Page 202) - DONE

5. Modify the QVDirectoryServiceConnector.exe.config file by changing the UseHTTPS value from false to TRUE. (Page 202) -DONE

6. SSL on QlikView Publisher (pg 209)

  • The config file for each service must be changed. - DONE (see above)
  • In C:\ProgramData\QlikTech\WebServer\config.xml (C:\Documents and Settings\All Users\Application Data\QlikTech\WebServer\config.xml on older systems) change the setting <ConfigUrl>http://_:4750/qvws.asmx</ConfigUrl> to include https instead of http. - DONE.


6.3 It is important that the URL for the services match the URL in the certificate. The settings must be changed in the user interface: System, Setup, Service, General, Location.

- This is also where I need assistance.

If my certificate's URL is https://qv.mycompany.com, then what exactly do I change each service's URL location to in the QEMC?

How many and what places in the QEMC do I need to make this change?



Tags (2)
1 Solution

Accepted Solutions
sjoelsona8
New Contributor III

SSL on QlikView Publisher (Version 10)

  • I uninstalled Qv 10 Server and re-installed to use IIS as the web server.
  • I then configured SSL using IIS using the reference manual and assistance from support.


Works like a charm.

12 Replies
sjoelsona8
New Contributor III

SSL on QlikView Publisher (Version 10)

Has anyone successfully configured QV10 server for SSL? Can you offer any insight to my questions above in bold? Thanks in advance!

Not applicable

SSL on QlikView Publisher (Version 10)

Scott,

Have you been able to configure SSL on your system yet?

sjoelsona8
New Contributor III

SSL on QlikView Publisher (Version 10)

Not yet. I have opened a case with support. I'll share my resolution when I have one.

sjoelsona8
New Contributor III

SSL on QlikView Publisher (Version 10)

  • I uninstalled Qv 10 Server and re-installed to use IIS as the web server.
  • I then configured SSL using IIS using the reference manual and assistance from support.


Works like a charm.

Not applicable

SSL on QlikView Publisher (Version 10)

Hey Scott,

Two quick questions -

1) Did you find any answers from the support regarding your questions in bold above?

2) Were you able to finally set up SSL with QV WebServer instead of IIS?

Please let me know.

sjoelsona8
New Contributor III

SSL on QlikView Publisher (Version 10)

I successfully set up SSL with the QVWS instead of IIS.

(Note: I only set up SSL for the AccessPoint portal, not for the QlikView services or Publisher).

Steps:

1. Register your SSL certificate.

2. Edit the Config.xml file at C:\ProgramData\QlikTech\WebServer by adding the line <Url>https://QVS.companyx.local:443/</Url> on the first line inside the <Config> tag.

( Note: the Url should be the url for your certificate)

3. In the QEMC, go to System > Setup > QlikView Web Servers > General and change the Communication port to 443 and select the checkbox Use https.

awqvuser
Contributor

SSL on QlikView Publisher (Version 10)

Hi Scott,

Just wondering, what type of SSL Certificate did you apply for? Since QlikView Web Server is Apache-based, so I'm guessing it's an Apache since I don't see an option for Qlikview (among others are IIS, Citrix, Apache, etc). I just need some confirmation

Thank you

Anton

shelvinpatel
New Contributor III

SSL on QlikView Publisher (Version 10)

Hi Scott,

For one of my client, I have asked the IT Support to generat the certificate from an IIS certificate server within the domain and used that.

Also in v10, you don't need to amend config.xml file.  This was for v9 and it seems that the reference manual is not updated with the option available through QEMC in v10.

Thanks, Shelvin

Not applicable

Re: SSL on QlikView Publisher (Version 10)

Hi..

I have certificate file provided by client.

Now how to register and get SSL URL ...

Please help..

Thanks

Community Browser