Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Section Access/Distribution Issue

Hello,

Now, this is something that I have never encountered before. It just started occurring over the weekend

I have a Section Access Script that looks like this:

 

Section Access;

LOAD
text(USERID) as USERID,
     TEXT(PASSWORD) as PASSWORD,
     'MSWBH\' & text(NTNAME) as NTNAME,
     LASTNAME,
     FIRSTNAME,
        IF(LEN(TRIM(ACCESS)) > 0,'ADMIN','USER') AS ACCESS,
    TEXT(GROUP) as  GROUP,
    text(OMIT) AS OMIT
FROM
[..\..\..\Security.xlsx]
(ooxml, embedded labels, table is Sheet1);


Section Application;


Directory;
LOAD TEXT(GROUP) AS GROUP,
     ACCESS
FROM
[..\..\..\Security.xlsx]
(ooxml, embedded labels, table is Sheet2);

The Group Info is as follows:

GROUPACCESS
GROUP10
GROUP21

I use the group setup to hide certain fields from users from Group 1 that are included in the OMIT field.

In the app, I also hide certain charts by adding the condition "sum(ACCESS) >= 1" which means that only those users that belong to GROUP2 can view those charts. We use Publisher to distribute the documents. So, after I reload the publish the document, the app in the Source document looks accurate. It assigns the correct group to the correct user. ( I tested that by giving myself restricted access and I observed that I could see one row in the group table that had GROUP 1 AND 0).

However, when I look at it from Accesspoint, I see that everything that should be hidden is still visible. I also see in the table viewer that the group info has been reversed, i.e. GROUP 2 AND 1. That is the reason why the objects are not hidden, even though data reduction takes place successfully

I am clueless as to why the Publisher would change this on the fly.

Any thoughts?

2 Replies
Bill_Britt
Not applicable

Re: Section Access/Distribution Issue

Hi,

Not sure if this is your issue or not, but you need to make sure the Service Account has Administrator rights to the Document.

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
isaac_oliva
Not applicable

Re: Section Access/Distribution Issue

Hi,

I have the same problem and the service Account has administrator privileges.

any idea?

Thanks in advance.

Isaac.