Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Not applicable

Section Access not working when refreshing from Management Console

Hi

I developed a model and implemented Section Access.

The security is at sheet level.

I have included the Service account name with the account seeing all sheets.

When I refresh manually and open the model, the security works fine but when I refresh the model through Management Console the model seems to lose the security and all sheets are available to all users.

Any idea why this is or how I can fix it?

Regards,

Magen

5 Replies

Re: Section Access not working when refreshing from Management Console

can you please share the section access script ??

Have you checked the conditions properly ??

Re: Section Access not working when refreshing from Management Console

Section Access worked by design only by opening the application and each refresh or reload from users will leverage the protection. This meant you need to make sure that no refresh or reload from users is possible.

- Marcus

stabben23
Honored Contributor

Re: Section Access not working when refreshing from Management Console

Hi, if you exclude your service account where you load your sheet access, then it should work.

LOAD

.

.

.

FROM

[..\Qvds\Users-QlikView_Dev.xlsx]

(ooxml, embedded labels, table is [SHEET ACCESS])
where NTNAME <> "Your service account";

mov
Esteemed Contributor III

Re: Section Access not working when refreshing from Management Console

Section access is for the row level security.  Can be for the column level by using OMIT.

Could you please elaborate how exactly "The security is at sheet level" is implemented in your case? (I don't use section access for this.)

Employee
Employee

Re: Section Access not working when refreshing from Management Console

HI,

Do you have this set? Also, can you post your Section Access Script?

Untitled.png

Community Browser