Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Section Access with Loop and Reduce - error

Hi.

In connection with a Section Access setup, where an Admin user is granted access to all Countries by the use of a *, everything is working fine.

But when the Loop and Reduce function is added, resulting in different country versions of the Source dokument, it looks like the * functionalitet doesn't work. Suddenly the user gets an: access denied, allthough the user has been granted access to all data, and therefor also the data in a reduced dokument.

Is this a bug - or is the * functionality for some strange reason designed to (not) work like that.

1 Solution

Accepted Solutions
Support
Support

Re: Section Access with Loop and Reduce - error

Hi,

Blank should only be used for the service account that is doing the reloads and not in desktop.

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
3 Replies
Support
Support

Re: Section Access with Loop and Reduce - error

Hi,

The star in section access is a little tricky.  Lets say I have a country table with USA, France, Germany, Sweden and UK and my load statement is

Section Access;
LOAD * INLINE [
ACCESS, USERID, GROUP
ADMIN, ADMIN, *
USER, USER1, A
USER, USER2, B
USER, USER3, C
]
;
Section Application;

LOAD * INLINE [
GROUP, COUNTRY
A, USA
B, FRANCE
C, GERMANY
]
;

LOAD * INLINE [
COUNTRY, DATA
USA, 5
FRANCE, 10
GERMANY, 15
SWEDEN, 20
UK, 25
]
;

So when I run this and login as admin I see the below.

1.png

Notice I only see France Germany and USA. The reason  this happens is * means all listed values. This means Admin will see what User1, User2 & User3 sees.

If you want to see all the values, you need to remove the * and leave it blank.  Now when I reload Admin will see all the data.

2.png

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
Not applicable

Re: Section Access with Loop and Reduce - error

Hi BB.

Thanks for getting back. I should have mentioned, that I did find the reason for the problem. In a Section Application load I had the Section Access Table loaded, so that it's possible to see, what is going on in the Section Access section.

What I didn't remember was to Qualify the the relevant NTNAME and ACCESS field, and with the reduce function in play that created the confusion.

About the difference between blank and * loads. It looks like a "blank" load and Strict Exclusion doesn't play well together.

But as mentioned: I did get it to work. Thanks again.

Support
Support

Re: Section Access with Loop and Reduce - error

Hi,

Blank should only be used for the service account that is doing the reloads and not in desktop.

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.