Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Simple DB-Command Task in QVS/QV-Publisher 9 SR1??

Dear all,

I try to set up a simple DB-Command Task in QVS/QV-Publisher 9 SR1. But it seems to me that it doesn't work. There is also absolutely no documentation from QlikTech about this topic!

It would be kind, if anybody could provide a simple demo with a MS Access Database. I am especially interested in the syntax for the connection string.

Thank you very much.

Kind regards,
Fabian

PS: my error message is "Das Format der Initialisierungszeichenfolge stimmt nicht mit der Spezifikation überein, die bei Index 605 beginnt. [...]" (German)

3 Replies
Not applicable

Simple DB-Command Task in QVS/QV-Publisher 9 SR1??

Hello Fabian,

I agree with you about the documentation on QlikView 9. It's definitively lacking. Try working with EDX tasks from an external applicationSmiley Happy

The connection string seems to follow the standard used by SqlDataProvider in the .Net Framework. Have a look at http://www.connectionstrings.com for examples. I use SQL Server 2005 so I found a good example under http://www.connectionstrings.com/sql-server-2005.

My connection string looks like this:

Data Source=my_server;Initial Catalog=my_database;Integrated Security=SSPI;

I call a stored procedure with the following syntax, no EXECUTE and no ;.

InsertEdxStatus NULL,NULL,NULL,NULL,'Edx_User', 'A EDX task has completed.', NULL, 'username', 'username'

Best regards

Henrik

Not applicable

Simple DB-Command Task in QVS/QV-Publisher 9 SR1??

Hello Henrik,

thank you very much for your valuable answer.

Kind Regards,
Fabian

Not applicable

AW:Re: Simple DB-Command Task in QVS/QV-Publisher 9 SR1??

Database command is only available for SQL Server? I tried an oracle connection string and it didn't worked. Errotrmessage talks about namespace System.Data.SqlClient witch ist build SQL Server provider shipped with the .Net FW.

Is there a way to change default namespace from System.Data.SqlClient to Oracle.DataAccess.Client because both classes implements the same Interfaces.

Right now I use a workaround with an external CLI app.

Any suggestions to make it directly in QVP?

Geetings Boris.

Community Browser