Qlik Community

QlikView Publisher

Discussion Board for collaboration on QlikView Publisher.

Not applicable

Task status shows "Running" even it is completed successfully

Hi,


We have a qvw reload task, which is executed successfully but the task status is still showing 'running'. Please see the attachment.

Also,it is showing Abort button enable, but on clicking- it doesn't go to grey.

We recently upgraded server to 11.2 SR7. Is it a known issue?

Could anyone help me what is the problem.

Tags (4)
14 Replies
michielvandegoo
Valued Contributor

Re: Task status shows "Running" even it is completed successfully

Is your publisher set to 'Automatic refresh of task list'? (bottom right)

Not applicable

Re: Task status shows "Running" even it is completed successfully

No, 'Automatic refresh of task list' is unchecked. But I refreshed the web browser several times to check the task status.

vinafidalgo
Contributor

Re: Task status shows "Running" even it is completed successfully

Have you tried to add a Exit Script at the end of your script?

Not applicable

Re: Task status shows "Running" even it is completed successfully

exit script; code already exist at the end of my script.

vinafidalgo
Contributor

Re: Task status shows "Running" even it is completed successfully

I've faced the same problem one day.

The problem was that my script was creating Synthetic Keys and/or Circular Reference.

Try to add a trace to see how far the script is going, also check the RAM usage.

giakoum
Honored Contributor II

Re: Task status shows "Running" even it is completed successfully

This is an issue that is with us for a long time now. Same in SR8 & SR9.

We have not found any way to correct that.

Not applicable

Re: Task status shows "Running" even it is completed successfully

No issues with script, data model or RAM usage. App is executing successfully, but problem is with it's QMC task which shows 'running' status even after execution is completed successfully.

Not applicable

Re: Task status shows "Running" even it is completed successfully

Thanks giakoum.
But presently, is there a way to resolve this- except restarting the services?

giakoum
Honored Contributor II

Re: Task status shows "Running" even it is completed successfully

none I know of I am afraid.

Community Browser