Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

nstefaniuk
Contributor III

[10SR4] Oracle silent errors

Hello all,

I have an issue with 10 SR4.

The oracle errors are silent in SR4 when they are not in SR2.

With this code (after a CONNECT of course), you should get an Oracle error (dividing by zero).

data:

Load

*

;

SQL

select

1/0 "test" from dual

;

drop table data;

In SR2 i get the error but in SR4 I don't, and so in SR4 I just have the table missing error (because the table is not created).

I haven't found a parameter to manage it.

I am in 32 bits on Windows 7, but same in 64 bits on 2003 server

Thanks for help

11 Replies
MVP & Luminary
MVP & Luminary

[10SR4] Oracle silent errors

Hi,

it's working on my site with QV 10 SR4, QV11 on Oracle 10g & 11g, Win7 x64 with Oracle ODBC driver.

Which ODBC driver you're using?

Maybe you have set ErrorMode=0 ?

- Ralf

Not applicable

[10SR4] Oracle silent errors

Hi,

Same problem with ole-db Oracle connector

SET ErrorMode=1;

OLEDB CONNECT TO [Provider=OraOLEDB.Oracle.1;Persist Security Info=True;User ID=MyUser;Data Source=Mytable;Extended Properties=""] (XPassword is *******);

data:

Load

* ;

SQL

select

1/0 "test" from dual;

drop table data;

10/02/2012 14:20:14:      Début de l'exécution

10/02/2012 14:20:14:      QlikView Version:10.00.9282.8

10/02/2012 14:20:14:      CPU Target                    x86

10/02/2012 14:20:14:      Operating System              Microsoft Windows XP Service Pack 3 (32 bit edition)

10/02/2012 14:20:14:      Wow64 mode                    Not using Wow64

10/02/2012 14:20:14:      MDAC Version                  2.81.1132.0

10/02/2012 14:20:14:      MDAC Full Install Version     2.81.1132.0

10/02/2012 14:20:14:      PreferredCompression          0

10/02/2012 14:20:14:      EnableParallelReload          1

10/02/2012 14:20:14:      ParallelizeQvdLoads           1

10/02/2012 14:20:14:      AutoSaveAfterReload           1

10/02/2012 14:20:14:      BackupBeforeReload            1

10/02/2012 14:20:14:      EnableFlushLog                0

10/02/2012 14:20:14:      SaveInfoWhenSavingFile        0

10/02/2012 14:20:14:      UserLogfileCharset            0

10/02/2012 14:20:14:      OdbcLoginTimeout              -1

10/02/2012 14:20:14:      OdbcConnectionTimeout         -1

10/02/2012 14:20:14:      ScriptWantsDbWrite            false

10/02/2012 14:20:14:      ScriptWantsExe                false

10/02/2012 14:20:14:      LogFile CodePage Used:        1252

10/02/2012 14:20:14: 0002  SET ThousandSep=' '

10/02/2012 14:20:14: 0003  SET DecimalSep=','

10/02/2012 14:20:14: 0004  SET MoneyThousandSep=' '

10/02/2012 14:20:14: 0005  SET MoneyDecimalSep=','

10/02/2012 14:20:14: 0006  SET MoneyFormat='# ##0,00 €;-# ##0,00 €'

10/02/2012 14:20:14: 0007  SET TimeFormat='hh:mm:ss'

10/02/2012 14:20:14: 0008  SET DateFormat='DD/MM/YYYY'

10/02/2012 14:20:14: 0009  SET TimestampFormat='DD/MM/YYYY hh:mm:ss[.fff]'

10/02/2012 14:20:14: 0010  SET MonthNames='janv.;févr.;mars;avr.;mai;juin;juil.;août;sept.;oct.;nov.;déc.'

10/02/2012 14:20:14: 0011  SET DayNames='lun.;mar.;mer.;jeu.;ven.;sam.;dim.'

10/02/2012 14:20:14: 0012  set ErrorMode=1

10/02/2012 14:20:14: 0013  OLEDB CONNECT*Provider*XPassword*

10/02/2012 14:20:14: 0015  data:

10/02/2012 14:20:14: 0016  Load

10/02/2012 14:20:14: 0017  *

10/02/2012 14:20:14: 0019  SQL

10/02/2012 14:20:14: 0020  select

10/02/2012 14:20:14: 0021  1/0 "test" from dual

10/02/2012 14:20:14: 0025  drop table data

10/02/2012 14:20:14:       Erreur: Table non trouvée

10/02/2012 14:20:16:      Fin de l'exécution.

MVP & Luminary
MVP & Luminary

[10SR4] Oracle silent errors

Hm, I'm getting same error ORA-01476: Divisor ist Null also with OLEDB (Provider=OraOLEDB.Oracle.1).

- Ralf

Not applicable

[10SR4] Oracle silent errors

The error is normal, but do you have a error message ?

Because , I don't receive the message


Thanks,

Yann

MVP & Luminary
MVP & Luminary

[10SR4] Oracle silent errors

Of course, in the log file and in a popup window:

10.02.2012 15:22:15: 0014  OLEDB CONNECT*Provider*XPassword*

10.02.2012 15:22:16: 0017  data:

10.02.2012 15:22:16: 0018  Load

10.02.2012 15:22:16: 0019  *

10.02.2012 15:22:16: 0021  SQL

10.02.2012 15:22:16: 0022  select

10.02.2012 15:22:16: 0023  1/0 "test" from dual

10.02.2012 15:22:16:       Error: ErrorSource: OraOLEDB, ErrorMsg: ORA-01476: Divisor ist Null

MVP & Luminary
MVP & Luminary

[10SR4] Oracle silent errors

ODBC version:

10.02.2012 15:25:22: 0016  ODBC CONNECT*XUserId*XPassword*

10.02.2012 15:25:23: 0018  data:

10.02.2012 15:25:23: 0019  Load

10.02.2012 15:25:23: 0020  *

10.02.2012 15:25:23: 0022  SQL

10.02.2012 15:25:23: 0023  select

10.02.2012 15:25:23: 0024  1/0 "test" from dual

10.02.2012 15:25:23:       Error: SQL##f - SqlState: 22012, ErrorCode: 1476, ErrorMsg: [Oracle][ODBC][Ora]ORA-01476: Divisor ist Null

Not applicable

[10SR4] Oracle silent errors

Thanks,

What is your version of Ole-db connector ?

MVP & Luminary
MVP & Luminary

[10SR4] Oracle silent errors

It's OraOLEDB11.DLL version 11.1.0.6.0, same as ODBC version.

Not applicable

[10SR4] Oracle silent errors

For me it's OraOLEDB10.dll version 10.2.0.1, I'll try to change my Oracle connector.

Thanks.

Community Browser