Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
If you are a Qlik Insight Bot user, join this collaborative group: JOIN GROUP
Highlighted
New Contributor III

All my queryes go to the same resyult table, am i missing something

Hello

I have one script  with  3 queryes , 

When i load de data i would expect to create c1, c2 and c3, but instad everything goes to c1,   What am I missing ?   (i have used QS but new with QV)

c1 << T_QUERY 13 lines fetched

c1 << T_QUERY 30 lines fetched

c1 << T_QUERY 45 lines fetched

This is part the script

c1:

load

CANT_QRY_1,

CANT_USERS;

sql select

CANT_QRY_1

CANT_USERS

where

CRR_ID_QRY = 1

;

c2:

load

CANT_QRY_2,

CANT_USERS;

sql select

CANT_QRY_2,

CANT_USERS

where

CRR_ID_QRY = 2

;

c3:

load

CANT_QRY_3,

CANT_USERS;

sql select

CANT_QRY_3

CANT_USERS

where

CRR_ID_QRY = 3

;

4 Replies
Highlighted
Valued Contributor II

Re: All my queryes go to the same resyult table, am i missing something

hi,

may be comma's missing in sql select?

CANT_QRY_1

CANT_USERS

Highlighted
New Contributor III

Re: All my queryes go to the same resyult table, am i missing something

Hi Oliver

No, it is not the ','    i just missed it when i rewrote the example, but it exists in my real query

Thanks

Camilo

Highlighted

Re: All my queryes go to the same resyult table, am i missing something

Are you sure, you are using the different field names with these 3 tables?

May be try to use 'No Concatenate' between those tables.

New Contributor III

Re: All my queryes go to the same resyult table, am i missing something

Hello Settu

I added noconcatenate , and it woerked

Thanks!!