Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

AllowExecuteCommand setting violation detected

Hi Guys.

Error : AllowExecuteCommand setting violation detected

i'm getting this error while trying execute a batch files, it works fine when i'm using QV11, i just upgrade my qvs into QV12.

i've try this 2 solution :

1. i already try add this line : AllowExecuteCommand=1 in settings.ini (already restart all services but it doesn't work.)

2. already try to change user preference, tab security, check script (allow database write and execute statement)


i've seen this thread :

Allow EXECUTE statement in QlikView 12

https://community.qlik.com/thread/211162

Any Solution ?

Thanks.

19 Replies

Re: AllowExecuteCommand setting violation detected

Hi,

Hope you have done the setting in Edit Script, Settings, "Can Execute External Command".

Regards,

Kaushik Solanki

Not applicable

Re: AllowExecuteCommand setting violation detected

error execute.png

Yes, i have..

krishnacbe
Valued Contributor III

Re: AllowExecuteCommand setting violation detected

Hi

Check whether the user has access to execute batch scripts.

Local Policy Groups -> Login as Batch User

The user should be part of this group. Hope this helps

Not applicable

Re: AllowExecuteCommand setting violation detected

which one ? my qlikview service run as Administrators Group

i double click the batch file, it works fine. but i want to make it works in my qlikview file and schedule in qlikview server.

i guess add this script "AllowExecuteCommand=1"  is useless...

Please Qlikview Support Team.. Help Me..

krishnacbe
Valued Contributor III

Re: AllowExecuteCommand setting violation detected

Follow below process in your server and verify whether the Service account is added here.

1. In the Control Panel ->  Open Administrative Tools -> Local Security Policy

2. Open Local Policies and highlight User Rights Assignment.

3. Locate Log on as a batch job. Open the properties and check the service account is part of this.

As you have logged into the server with the same credential you were able to run the batch. But the above settings will allow the batch to run remote that is by QMC/Windows task

mjamesking
Contributor

Re: AllowExecuteCommand setting violation detected

I've just come across this problem where my scheduled tasks were failing due to this setting violation following an upgrade to QVS12.  I struggled for a while, contact support and we worked out what I was doing wrong. Solution below:

1. I'd already tried the suggested solution to add AllowExecuteCommand=1 to Settings.ini. Stopped qlikview services, restarted services after saving the change. Didn't work.

2. Turns out i was updating the wrong Settings.ini file. I was updating the one in the QllikView Server folder. The one you need to update is here C:\Windows\System32\config\systemprofile\AppData\Roaming\QlikTech\QlikViewBatch

Update the Settings.ini file here, setting AllowExecuteCommand=1 stop services, save changes, restart services.

3. Fixed.

MVP
MVP

Re: AllowExecuteCommand setting violation detected

Hi mjamesking‌,

Thanks for sharing up this solution - just saved me a lot of head scratching.

aditya.christian‌ did this work for you also?  Please mark it as the correct answer if it did.


Steve

cva1962
New Contributor

Re: AllowExecuteCommand setting violation detected

Thanks for sharing.

This helpt me at once in QV 12.10 SR4 upgrade from 12.10 IR!!!

Christer

Re: AllowExecuteCommand setting violation detected

Community Browser