Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

paulyeo11
Valued Contributor II

Already create link key for 2 Table but two table not link ?

Hi All

    autonumber( @1:9T & '_' & 'TDSS' ) as ARKey_,

I have create the above script at Payment_SG and AR_SG Tab

   @10:38T as [COMPANY_PAY],

I have create the above script at  Payment_SG tab

left(@10:38T,25) as [company_ap],

I have create the above script at  AR_SG tab

Why these 2 table still not link ? can some one advise me where i go wrong ?

Paul

1 Solution

Accepted Solutions
prma7799
Honored Contributor III

Re: Already create link key for 2 Table but two table not link ?

Just rename SOURCE and Cust_ID from ARS_SUMMARY table and try ..

25 Replies
paulyeo11
Valued Contributor II

Re: Already create link key for 2 Table but two table not link ?

my QVW

Re: Already create link key for 2 Table but two table not link ?

I don't have license to open your qvw. Here i think you are creating Link table and not give the same name to link..

paulyeo11
Valued Contributor II

Re: Already create link key for 2 Table but two table not link ?

Hi Anil

I have try to copy and paste

autonumber( @1:9T & '_' & 'TDSS' ) as ARKey_,

to both Tab , it still not work.

Paul

Re: Already create link key for 2 Table but two table not link ?

When you say, It's not working. I would expect some clue whether any error or what? I am sorry, I don't have license to check if though i may offer you better on fly )

paulyeo11
Valued Contributor II

Re: Already create link key for 2 Table but two table not link ?

Hi Anil

See the below pic

not link terms.png

Re: Already create link key for 2 Table but two table not link ?

It's been Associate to Synthetic Keys and link also there. I would suggest in high prior related Synthetic key. Would you like to remove synthetic keys and check it may link to each other when we remove synthetic keys

Synthetic table\keys in QlikView – and how to avoid it | Tech Updates

paulyeo11
Valued Contributor II

Re: Already create link key for 2 Table but two table not link ?

Hi Anil

After i remove the below script from Payment_SG Tab , it work fine now.

left(@10:38T,15) as [company],

Can you share with me why this cause the issue ?

Paul Yeo

Re: Already create link key for 2 Table but two table not link ?

Could be the reason, Seems you done twice and did multi tasking at a time

I have create the above script at Payment_SG and AR_SG Tab

@10:38T as [COMPANY_PAY],

I have create the above script at  Payment_SG tab

left(@10:38T,25) as [company_ap],

This creates split from one field to 2 fields. May be here the debug we required

HTH

Anil

paulyeo11
Valued Contributor II

Re: Already create link key for 2 Table but two table not link ?

Hi Anil

What is correct approach ?

I know it should not using different name for company , which is very confuse .

It should be only one name.

Paul Yeo

DIrector

TDS Technology (S) P/L

Whatsapp +65 9326 1804

www.tdstech.com<http://www.tdstech.com>

Community Browser