Qlik Community

Ask a Question

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
Talk to Experts Tuesday, January 26th at 10AM EST: Qlik Sense. REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
Creator III
Creator III

Asking password when trying to reload

Hi All,

I have connected to db with the following string;

OLEDB CONNECT TO [Provider=SQLOLEDB.1;XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX;

But when am trying to reload everytime its asking the password.How to avoid this.

Thanks,

Ajay

1 Solution

Accepted Solutions

Hi,

While creating connection, Make sure to select allow password saving.

Have a look at attached image.

Regards

ASHFAQ

View solution in original post

6 Replies

Hi,

While creating connection, Make sure to select allow password saving.

Have a look at attached image.

Regards

ASHFAQ

View solution in original post

Creator
Creator

You can chose to save the password

oledb.jpg

Creator III
Creator III

Thanks Ashfaq.The settings has been done earlier But when am checking in the mentioned connection name no word with Password only i have userid.

So is it i have to better to connect again to the DB with the option you mentioned in the image right?

Thanks ,

Ajay

Exactly.

Create new connection string and make sure you select Allow Saving Password.

Regards

ASHFAQ

Not applicable

If you have access to the database it should work with "Use Windows NT Integrated security" und Data Link Properties / Connection /2. Enter Information to log on to the Server.

It is generally advisable to have SSO (from your own client or from the Server you work from) rather than storing passwords in strings.

Creator III
Creator III

Thanks Asfaq and all.Its working.