Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Buffer (incremental) load: cannot find .qvd file

I'm trying to find out how 'BUFFER (incremental)' load works. I'm using the statement below to load data from a text file:

HourOverview:
BUFFER (Incremental)
LOAD
@1 as Time,
@2 as Category,
@3 as Activity
FROM
uur.log
(txt, codepage is 1252, no labels, delimiter is '\t', msq) ;

The data is loaded fine, but I would expect that a .QVD file was created in the default location (in my case C:\Documents and Settings\ddoord\Application Data\QlikTech\QlikView). However, there are no .QVD files in that folder (or any folder below). Are there some limitations on that I'm not aware of?

1 Solution

Accepted Solutions
Not applicable

Buffer (incremental) load: cannot find .qvd file

Hi Rob,

Thank you for checking!

As your help indicated that the script was correct, I've finally figured out the problem: I've searched in the wrong location. It shouldn't have been C:\Documents and Settings\ddoord\Application Data\QlikTech\QlikView but
C:\Documents and Settings\ddoord\Local Settings\Application Data\QlikTech\QlikView\Buffers. As it is a hidden directory, a windows search delivered no results with the standard search settings on!

Kind regards,

Daniel

3 Replies

Buffer (incremental) load: cannot find .qvd file

Your sample works fine for me on QV9 SR4. I get a QVD created in the buffer loacation.

-Rob

wizardo
Contributor III

Buffer (incremental) load: cannot find .qvd file

hmmm have you checked the settings:

this is from the inside qlikvie help:

QVD buffers will normally be removed when no longer referenced anywhere throughout a complete script execution in the document that created it or when the document that created it no longer exists. This housekeeping can be turned off by checking the options Keep Unreferenced QVD Buffers in Document Properties: General (first requirement) and Keep Orphaned QVD Buffers in User Preferences: General (second requirement) property pages respectively, though the procedure cannot be generally recommended.



Not applicable

Buffer (incremental) load: cannot find .qvd file

Hi Rob,

Thank you for checking!

As your help indicated that the script was correct, I've finally figured out the problem: I've searched in the wrong location. It shouldn't have been C:\Documents and Settings\ddoord\Application Data\QlikTech\QlikView but
C:\Documents and Settings\ddoord\Local Settings\Application Data\QlikTech\QlikView\Buffers. As it is a hidden directory, a windows search delivered no results with the standard search settings on!

Kind regards,

Daniel

Community Browser