Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Bug when loading CSV file with quotes

Hi,

I am loading up a flat file which has product names in. Some of these names have comas inside the description so the products have been wrapped in " (double quotes).

However any subsequent file is not loading. I believe that the script is not intepreting the code properly as there is only a single " (double quote) in the code.

.

.

.

FROM

[..\myproduct.csv]

(txt, codepage is 1252, embedded labels, comment is ", delimiter is ' ', msq);

anything after this seems to be intepreted as being inside quotes and no files after this load. i've tried various things to sort it out, but i guess it looks like i'll have to change the source data so that the quotes are removed and that the delimiter is different.

cheers

Tags (2)
1 Reply
pgrenier
Contributor III

Re: Bug when loading CSV file with quotes

Hello,

I believe the source of the problem resides in the comment parameter: There should be 2 " characters rather than only one.

LOAD *

FROM  [..\myproduct.csv] 

(txt, codepage is 1252, embedded labels, comment is "", delimiter is ' ', msq);


If you wish, you may also omit that parameter:


LOAD *

FROM  [..\myproduct.csv] 

(txt, codepage is 1252, embedded labels, delimiter is ' ', msq);


Regards,


Philippe

Community Browser