Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

Clarion TopSpeed ODBC Connection

New user of Qlik View Personal Edition (QlikView 11.20 SR13) on Windows 7 Pro, 32bit.

I have a DSN, let’s call it SMEG. This DSN works fine with MS Query/MS Excel or OpenOffice. It is using the Clarion TopSpeed read only driver to connect to the SMEG database.

I am trying to connect to this DSN in Qlik.

I have created an additional user DSN as well as the existing system DSN with no success.

I create a new blank file and edit the script. I use ODBC and hit the connect button. I have tried with both force 32bit on and off. I can select SMEG from the data source. Test connection is successful. Press OK.

Press the select button to select my tables and fields. This is where the problem is. The data source is listed, SMEG.

The database and fields drop down menus are grayed out, I can’t select any tables or fields. The driver button reports many details relating to the Clarion driver.

I am sure that I am missing something basic.

The support button from the connection statement window reports the following:




SQL_DBMS_NAME                 TOPSPEED

SQL_DBMS_VER                  01.00.0000


SQL_DRIVER_VER                5.00.0008

SQL_DRIVER_ODBC_VER           03.00

SQL_ODBC_VER                  03.80.0000

Does anybody have an idea where I am going wrong?

1 Reply
Not applicable

Re: Clarion TopSpeed ODBC Connection

Would it help to show my connection string?

I have tried:

ODBC CONNECT TO [Smeg;DBQ=C:\Smeg\Data\];


ODBC CONNECT32 TO [Smeg;DBQ=C:\Smeg\Data\];

I downloaded MS Power BI Desktop for comparison and I had a similar issue, the ODBC connection had issues, so I copied and pasted my MS Query connection string and it worked:

ODBC (dsn=Smeg;dbq=C:\Smeg\Data\;description=Smeg ODBC;extension=tps)

And here is the start of my MS Query connection string:

DSN=Smeg;DBQ=C:\Smeg\Data\;Description=Smeg ODBC;Extension=tps;

Or course I have tried variants of these connection strings that work with other software in Qlik, however I must be getting the syntax wrong or perhaps there is another issue.