Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

oscarmqz
Contributor III

Complex section access bridge table not working

Hi, I'm having an issue with section access when using multiple fields, I've followed the instructions in here:

http://community.qlik.com/blogs/qlikviewdesignblog/2012/10/02/complex-authorization

open attachment on below comment to see script

I've have the initial data reduction checked, and I've tried both with strict exclusion and without checking it, same result...

It works just fine in my desktop qlikview, but once in the access point, it is not working

If I set my access to <ALL>|<ALL>|<ALL>|<ALL> it will let me see it, but if I replace any of the fields then it will say I don't have access, for example <ALL>|PPS|<ALL>|<ALL> (but in desktop I do have access and it reduced to PPS only)

Thanks in advance for your help!

14 Replies
stabben23
Honored Contributor

Re: Complex section access bridge table not working

Hi Oscar,

I don´t know but you have a lot of startbrackets that dont have a endbracket in the Bridge part. You also have a endbracket in performance.

Not applicable

Re: Complex section access bridge table not working

Hi Oscar,

Can you please share an sample application with sample data to work with.

Regards,

Vasim

oscarmqz
Contributor III

Re: Complex section access bridge table not working

Hi, thanks for your help, the brackets is my bad, I tried to simplify the script to post the question. I'm attaching the file, the whole load scripts are there. I've commented the section access script and unchecked the reduction and strict exclusion so you can open the document.

Not applicable

Re: Complex section access bridge table not working

Hi Oscar, Please check the section access table have the ADMIN QVSERVICE account name ?

oscarmqz
Contributor III

Re: Complex section access bridge table not working

Hi Dathu, Im not sure what you mean, I do am including a system account, the one that runs the refreshes, as I'm not an admin and this process is driven by a external team.

Sent from my Samsung Mobile

Regards,

Oscar Marquez

Not applicable

Re: Complex section access bridge table not working

Hi Oscar,

Thanks for sharing the file.

But when i am trying to open your document ,i get this error of failed to open the document.

Regards,

Vasim

oscarmqz
Contributor III

Re: Complex section access bridge table not working

Hi  Vasim,

     I'm not sure why you would get that message, unless you have a personal license, I've deactivated data reduction and strict exclusion, also I refreshed it without section access before uploading it. Any ideas?

Not applicable

Re: Complex section access bridge table not working

Hi Oscar, I am suspecting the %KEY Section Table having the same data in BridgeTable.

Please check the data in new qvw file.

Please provide the sample data for your script.

oscarmqz
Contributor III

Re: Re: Complex section access bridge table not working

Hi Dathu,

     Here's the attachment with the files I'm using. I'm not really sure what you meant with "same data". Thanks for your help, I really appreciate it.

Community Browser