Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

luis_idrovo
Contributor

Conexion a Oracle 10g no me muestra tablas

Hola a todos,

Veran estoy intentando hacer una conexion desde un equipo con windows 7 el cual tiene instalado el cliente de oracle, cuando se realizo la conexion odbc salio prueba exitosa , ahora cuando realice la conexion desde qlikview con ese odbc que cree me sale todo bien pero cuando listo las tablas a las que tengo permisos solo me muestra una tabla, incluso realizo la conexion con un usuario que tiene todos los permisos pero desde qlikview no veo ninguna tabla; si realizo dicha conexion odbc desde excel por ejemplo si puedo hacer select a las tablas sin problemas. Tambien probe con una maquina virtual con windows xp con el mismo resultado, no me muestra las tablas.

Alguien me puede dar alguna ayuda.

Muchas Gracias de antemano

4 Replies
Not applicable

Conexion a Oracle 10g no me muestra tablas

¿Que version de qlikview utilizas 32 o 64 bits?, en alguna ocasión he tenidro problemas para conectar a Oracle por diferencia de versiones entre el conector (32 bits) y qlikview (64 bits), no obstante en la parte inferior de la pantalla de script figura una opción para forzar el uso de conectores en 32 bits. Pruebalo y quizas se solvente asi. Un saludo.

luis_idrovo
Contributor

Conexion a Oracle 10g no me muestra tablas

En el equipo con windows 7 uso qlikview 64 bits y si use el checkbox para forzar a 32 bits, en el equipo virtual con windows xp use qlikview de 32 bits

Employee
Employee

Conexion a Oracle 10g no me muestra tablas

Seguro que es una tontería, pero cuando vas al asistente para crear una sentencia select, tienes un desplegable para seleccionar el 'propietario' de la base de datos, o en terminología Oracle el esquema. Si el usuario con el que accedes tiene permisos para más de un esquema deberías seleccionar el esquema al que quieres acceder.

Otra tontería... estas seguro de que son tablas? a lo mejor son vistas y necesitas marcar el check box.

saludos, F.

luis_idrovo
Contributor

Conexion a Oracle 10g no me muestra tablas

Pues si estoy seguro que son tablas y tambien selecciono el propietario

Community Browser