Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

spring101
New Contributor III

Data Corruption Issue

Good Afternoon,

We have run into an issue where a QVD loader builds bad data every other run. Some of the values that are populated are as follows:

th

rk

um

|MN|-6|1

|MD|-5|1

er

These field values should be (and the format is always the same as #####A):

12346e

23423c

23423e

88932e

12300c

99824c

Has anyone ever run into this? It's very odd in that if I were to rerun this loader these records would be fixed. Also, other fields on the same rows are sometimes corrupted (such as persons names). This loader builds a QVD with about 480,000 records.

Thanks!

Tom

Tags (2)
1 Solution

Accepted Solutions
MVP
MVP

Re: Data Corruption Issue

I'm confused by the data you ARE getting, and it only happening every other run. But I do understand why QlikView would have problems with these values. Records that have all numeric digits with a single e, c, or d in them (?) are interpreted as some sort of exponential numeric format. If that's what's going wrong, the solution is to wrap the field in text() when reading it in so that QlikView doesn't try to interpret the data numerically.

2 Replies
MVP
MVP

Re: Data Corruption Issue

I'm confused by the data you ARE getting, and it only happening every other run. But I do understand why QlikView would have problems with these values. Records that have all numeric digits with a single e, c, or d in them (?) are interpreted as some sort of exponential numeric format. If that's what's going wrong, the solution is to wrap the field in text() when reading it in so that QlikView doesn't try to interpret the data numerically.

spring101
New Contributor III

Re: Data Corruption Issue

I'm going to say that this helped though it is such an inconsistent issue it's hard to know that this was or will be the fix. The good news is that in the past couple of days with this change I've not seen any errors.

Community Browser