Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Data reload not showing after saving

Hi all,

I'm loading some extensive .xml files into my Qlikview document and noticing that there's nothing wrong with the data reload, nor with the expressions I have applied to my graphs / tables.  I am extracting data out 7 .xml files in total, with 4 of these being primary tables for my graphs / tables.

However after saving the Qlikview document and closing the file, upon reopening the document only 3 out of the 4 data sources is having it's information displayed.  Reloading extracts the data out of the last source, however I don't know why the graphs / tables aren't being saved after saving the file.  There are no error messages populating with the reload.

What is the error and how do I fix this issue?

Thanks.

1 Solution

Accepted Solutions
mov
Not applicable

Re: Data reload not showing after saving

Hi Nathan,

Are you saying that the file after reload looks correct, and after you save and re-open some data is missing?  This can happen if you have Section Access with data reduction.

Regards,

Michael


3 Replies
mov
Not applicable

Re: Data reload not showing after saving

Hi Nathan,

Are you saying that the file after reload looks correct, and after you save and re-open some data is missing?  This can happen if you have Section Access with data reduction.

Regards,

Michael


Not applicable

Re: Data reload not showing after saving

Hi Michael,

Thanks for the quick response.

Yes what is asked is exactly what's happening.

I have applied section access to the tables but don't think I've applied anything different to the 1 out of 4 tables which doesn't populate after reloading and saving.

Unless I've missed something, is there a main method in over-coming this issue?

Regards,

Nathan

Not applicable

Re: Data reload not showing after saving

Hi Michael,

I've just re-revised my scripts and it seems I've applied a column which exists from another table in the table that wasn't initially saving.  This may have had something to do with Section Access but I think it was my own carelessness if anything!

I'd removed this and the graphs / tables began populating themselves immediately after saving, closing and reopening.

Regards,

Nathan