Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

johnnykhlee
New Contributor

Disable auto-labeling on wildcard table loading

Hi all,

I have several Excel files with the exactly same structure. When I try to load them all while some fields are unqualified, it auto-numbers the label. How can I use one label instead of several?

My code is as follows,

QUALIFY *;

UNQUALIFY id;

MyList:

LOAD id, name, company FROM List*.csv;

UNQUALIFY *;


When the tables are loaded, I get MyList.name, and MyList.company. But I also got MyList-1.name, and MyList-1.company, etc.


Is there's a way I just get a single table like I didn't specify QUALIFY/UNQUALIFY at all?


Thanks a lot.


-jl

1 Solution

Accepted Solutions
Highlighted

Re: Disable auto-labeling on wildcard table loading

May be do it this way

MyListTemp:

LOAD id,

    name,

    company

FROM List*.csv;

QUALIFY *;

UNQUALIFY id;

MyList:

LOAD *

Resident MyListTemp;

DROP Table MyListTemp;

View solution in original post

2 Replies
Highlighted

Re: Disable auto-labeling on wildcard table loading

May be do it this way

MyListTemp:

LOAD id,

    name,

    company

FROM List*.csv;

QUALIFY *;

UNQUALIFY id;

MyList:

LOAD *

Resident MyListTemp;

DROP Table MyListTemp;

View solution in original post

Highlighted

Re: Disable auto-labeling on wildcard table loading

Perhaps this Way?

QUALIFY *; 

MyList: 

LOAD id, name, company FROM List*.csv; 

UNQUALIFY *;


[MyList-1]:

Load * From ....

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)