Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Error: ODBC read failed

While loading the access database(ODBC connection) I got the following error:

Error: QVX_UNEXPECTED_END_OF_DATA: SQL##f - SqlState: S1000, ErrorCode: 4294966090, ErrorMsg: [Microsoft][ODBC Microsoft Access Driver] Cannot open database '|'.  It may not be a database that your application recognizes, or the file may be corrupt.

I extracted a fresh copy of the database and tried again, but even then the same error pops up.

How to solve this?

Tags (4)
4 Replies
Not applicable

Re: Error: ODBC read failed

phaneendra_kunc
Valued Contributor III

Re: Error: ODBC read failed

Have you tried OLEDB connection instead of ODBC?

Not applicable

Re: Error: ODBC read failed

No have not tried... But when I commented a field with memo datatype it seemed to work fine. But I need that field.. What to do?

Not applicable

Re: Error: ODBC read failed

The memo field should work fine with an ODBC connection.  But it could always be an issue with your particular ODBC driver, and of course I've not tested across versions, etc.

If the memo field is the only column that consistently causes the load to fail, perhaps you can string converting the type to string.  You could do this by calling CStr() in your SELECT (again, assuming you are using ODBC against MS-Access), so something like this:

SQL SELECT

     CStr(MyMemoField) As MyField

FROM Table1;

Or you could do this in your MS-Access database as a query, then just SELECT the query instead of the table.