Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

joaquinlr
Valued Contributor II

Error loading a XML file

Hello:

I'm trying to data from a XML file, but I get this error message

Found a not valid character 

On line number: 11. On column number: 12. System ID: MasVoz%20Demo.xml.

callATC:

LOAD account,

    calldate,

    cdrHost,

    destination,

    disposition,

    duration,

    id,

    province,

    service,

    source,

    hasrecord,

    played,

    hasfax

FROM [MasVoz Demo.xml] (XmlSimple, Table is [callATC])

On line 11 there is this content

<province>móvil</province>

QlikView doesn't like de word móvil ... a word with an accent mark

Is there a keyword or any way for loading XML files with accent mark words ??

I've attached the XML, it could help to test anything.

Thank you very much

Joaquín

1 Solution

Accepted Solutions
Frank_Hartmann
Honored Contributor

Re: Error loading a XML file

try opening the xml file with notepad++ and change encoding to UTF-8 ("convert to UTF-8"). Then save and try again loding the xml with qlikview!

Hope that helps

3 Replies
MVP & Luminary
MVP & Luminary

Re: Error loading a XML file

Maybe this is helpful: Re: Re: Caractere inválido em load de XML

- Marcus

Frank_Hartmann
Honored Contributor

Re: Error loading a XML file

try opening the xml file with notepad++ and change encoding to UTF-8 ("convert to UTF-8"). Then save and try again loding the xml with qlikview!

Hope that helps

joaquinlr
Valued Contributor II

Re: Error loading a XML file

Hello:

The content of the XML file was in UTF-8 format but I previously saved it in ANSI format.

I have saved the file in UTF-8 format and finally IT WORKS NICE ... just as Frank wrote.

Thanks for you help

Joaquñin