Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Error loading from the scheduler, and loading from the script goes fine

Hello! Help to solve the problem: when loading data in the desktop version, the boot is performed without problems, but when executing the load from the scheduler it drops into an error, when examining the log file I drew attention to the following lines:

Error: Error in expression:

Week takes 1 parameter

General Script Error

Execution Failed

Execution finished.

I use the parameter when defining the "week" and I really need it.

calendar:

LOAD        

         [TempDate] as tmp_date,

         Day([TempDate]) as [DAY],

         Week([TempDate],0,1) as [WEEK_NO],

         WeekName([TempDate]) as [WEEK_YEAR],

         WeekDay([TempDate]) as [DAY_OF_WEEK],

         Month([TempDate]) as [MONTH],

         MonthName([TempDate]) as [MONTH_YEAR],

         Dual('КВ'&Text(Div(Month([TempDate]),4)+1),Div(Month([TempDate]),4)+1)    as [QARTER],

         QuarterName([TempDate]) as [QARTER_YEAR],

         Year([TempDate]) as [YEAR]

Help, please, how to get out of this situation and why when executing the script from the application there are no errors, but when executing from the scheduler an error occurs?

1 Solution

Accepted Solutions
devarasu07
Honored Contributor II

Re: Error loading from the scheduler, and loading from the script goes fine

Hi,

Try to use

Week(weekstart([TempPeriod]))  as Week_No

or

    Week(CalDate) as Week_No,

2 Replies
devarasu07
Honored Contributor II

Re: Error loading from the scheduler, and loading from the script goes fine

Hi,

Try to use

Week(weekstart([TempPeriod]))  as Week_No

or

    Week(CalDate) as Week_No,

Not applicable

Re: Error loading from the scheduler, and loading from the script goes fine

Hello! Thanks for the help! the decision with this line helped: Week(weekstart([TempPeriod]))  as Week_No